summaryrefslogtreecommitdiff
path: root/sys-auth/pam_ssh_agent_auth/pam_ssh_agent_auth-0.10.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_ssh_agent_auth/pam_ssh_agent_auth-0.10.4.ebuild')
-rw-r--r--sys-auth/pam_ssh_agent_auth/pam_ssh_agent_auth-0.10.4.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys-auth/pam_ssh_agent_auth/pam_ssh_agent_auth-0.10.4.ebuild b/sys-auth/pam_ssh_agent_auth/pam_ssh_agent_auth-0.10.4.ebuild
index d633a44c02ec..d09b0fea56c1 100644
--- a/sys-auth/pam_ssh_agent_auth/pam_ssh_agent_auth-0.10.4.ebuild
+++ b/sys-auth/pam_ssh_agent_auth/pam_ssh_agent_auth-0.10.4.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools toolchain-funcs pam
+inherit autotools toolchain-funcs pam flag-o-matic
DESCRIPTION="Simple module to authenticate users against their ssh-agent keys"
HOMEPAGE="http://pamsshagentauth.sourceforge.net"
@@ -52,6 +52,9 @@ src_prepare() {
src_configure() {
pammod_hide_symbols
+ # bug #874843, use POSIX type names
+ use elibc_musl && append-cppflags -Du_char=uint8_t -Du_int=uint32_t
+
# bug #725720
export AR="$(type -P $(tc-getAR))"