summaryrefslogtreecommitdiff
path: root/sys-block/nbdkit
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/nbdkit')
-rw-r--r--sys-block/nbdkit/Manifest2
-rw-r--r--sys-block/nbdkit/nbdkit-1.42.0.ebuild130
2 files changed, 132 insertions, 0 deletions
diff --git a/sys-block/nbdkit/Manifest b/sys-block/nbdkit/Manifest
index 393372f61438..c59752e279d5 100644
--- a/sys-block/nbdkit/Manifest
+++ b/sys-block/nbdkit/Manifest
@@ -1,6 +1,8 @@
AUX nbdkit-1.32.4-automagics.patch 5620 BLAKE2B dca814d7d72607dd55284a58261820cf1b065ae1047846158a1e71d78c5182c060e653b89cf786ca9d7fe72514d5f034a2d4350b97a1b007f03eca7834c97e71 SHA512 52741eb9f04e5c40db0cc80e81000dd272d755de311d8ebe42ae16fa373e87ae887afc2153d0e51ff6676200ecaca31ecdab34704957e1090de0a645e8f39ce9
DIST nbdkit-1.32.4.tar.gz 2342420 BLAKE2B 3ea6692a534548707bc488560b0f0bd0ddeb0daa4b2432da5de18a9a735408370c61b8c0a30d7d4ed6c915eb118948d2462ff4565036bec8a77c2c2fb712f4da SHA512 0eb1f0f492ce3558fba8d472b26f7ca3db7beeba411c98e7e06b55c5456399be56f6b4cd4adb54567f744f8e07986af9f676a983da052d174ce2e3c28109dbc5
DIST nbdkit-1.36.1.tar.gz 2400838 BLAKE2B afbfbda18122b17cbcdcc5b3a04ab37b7dffb139d084b196ef45e33717f376af61189beb63b2541444eaae0ed860b752c20cfe9cf27bf06bfb04bba1b5ce60c8 SHA512 ca0e6e6729fb6f43a9717a3815dfb8ff54a2f182ef079e72b0e5e1b018c55f2205be52a10abc0b0a2243d0737f27b1ccf67c0d9586135454a460d39dad79f042
+DIST nbdkit-1.42.0.tar.gz 2591226 BLAKE2B ee92187d3697c45289f0f1872bd39bce04c64c88b7c8e0551588db704062c699d2996ee729b50a526527107e899e83c09871990ef080416c56f18d9e65ab3a19 SHA512 c8360fc2d9e6806ab241dcd61da82f52a881dd394d2e6c8c5372d4920f0751fe20dfe9bf45ff35c34cd1e12fd35d2b7dcf17374387805ff6cdec599c543c6bdc
EBUILD nbdkit-1.32.4.ebuild 2634 BLAKE2B afbcebb68f54b58d6542b0750f641269d87d8bc5dcf5c2f64f135d5ab931b7ed703908914d464d75c9d841950fbd0126e0f9bf89bce09016cb38f208e6667656 SHA512 70b223d21129eab207030a7ab6173d740f8dbb19d253289529cbfcdace013d68c35930596e3606b68a8247b7d2be63f593a4fb3c1dcb5f2fc183a2eaf6420e6a
EBUILD nbdkit-1.36.1.ebuild 2797 BLAKE2B a999d389fbd8cdb1850b5b4173b89e6bfbdfe7eff3ffed22e18911607b1fd756e175ee805a6b47e741e58a3c91c0322423d86a34dcf41144e9858854afe62046 SHA512 a4f78e3346a7cc4902db528c13f5aa324f8c131886ac4b8dbc563b75dd72129b59a70bf1ec6ade04812aa464dfe6346475bf0d4baf79bd0e3c23dd800c19bb6e
+EBUILD nbdkit-1.42.0.ebuild 3074 BLAKE2B 4f0ad08821c78c792776b6ff9e5329d4009abc7ff10af393b9f42ea9cf71c66b7a8998fe5b85030801609a0a8a41113a2932a399b6cfd413e3ac49783c5ad296 SHA512 d905634a08596453d89c4359f8b9679c3ecc67f9a1f78e3aac09744721d0ae3cb5135659efacffd8b1cfbf107022b416ad8b046a8e1e6a6148f5e6dcd0fcab2c
MISC metadata.xml 952 BLAKE2B 6f4ece7740fa9dda44a3036418469aa405ce1bdb91b1895f26dcc6e35603f08533831043d5fbb8e0123f3df7f6133cd00c0ddc3e5100df0d399afab119e7a13e SHA512 9516e1708ddf1b2cd11fc02dd6030480fc3f66d76596596c76fe766fd594b39ae0309f115ab06b1e23e1760d8bf51f99196be7c8fd67b7f507c5eb6cd8806418
diff --git a/sys-block/nbdkit/nbdkit-1.42.0.ebuild b/sys-block/nbdkit/nbdkit-1.42.0.ebuild
new file mode 100644
index 000000000000..cc5ea19e8eae
--- /dev/null
+++ b/sys-block/nbdkit/nbdkit-1.42.0.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit autotools bash-completion-r1 optfeature python-single-r1
+
+DESCRIPTION="NBD server with stable plugin ABI and permissive license"
+HOMEPAGE="https://gitlab.com/nbdkit/nbdkit"
+SRC_URI="https://download.libguestfs.org/nbdkit/$(ver_cut 1-2)-stable/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE="
+ curl ext2 nbd gnutls libguestfs libssh libvirt lzma selinux python
+ torrent valgrind zlib zlib-ng zstd
+"
+
+RDEPEND="
+ virtual/libiconv
+ selinux? ( sys-libs/libselinux )
+ gnutls? ( net-libs/gnutls:= )
+ curl? ( net-misc/curl )
+ libssh? ( net-libs/libssh:= )
+ libvirt? ( app-emulation/libvirt:= )
+ zlib? ( sys-libs/zlib )
+ zlib-ng? ( sys-libs/zlib-ng )
+ nbd? ( sys-libs/libnbd )
+ lzma? ( app-arch/xz-utils )
+ zstd? ( app-arch/zstd:= )
+ libguestfs? ( app-emulation/libguestfs:= )
+ ext2? ( sys-fs/e2fsprogs )
+ torrent? ( net-libs/libtorrent-rasterbar:= )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+ valgrind? ( dev-debug/valgrind )
+"
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+src_prepare() {
+ default
+
+ # TODO(arsen): This test fails for some reason.
+ cat <<-HACK > tests/test-file-extents.sh || die
+ #!/bin/sh
+ echo Gentoo: This test is skipped
+ exit 77
+ HACK
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-extra=Gentoo
+
+ --with-iconv
+ --with-manpages
+
+ $(use_with selinux)
+ $(use_with gnutls)
+ $(use_with curl)
+ $(use_with libvirt)
+ $(use_with zlib)
+ $(use_with zlib-ng)
+ $(use_with nbd libnbd)
+ $(use_with lzma liblzma)
+ $(use_with zstd libzstd)
+ $(use_with libguestfs)
+ $(use_with ext2)
+ $(use_with libssh ssh)
+ $(use_enable torrent)
+ $(use_enable valgrind)
+
+ --disable-linuxdisk # Not in Gentoo.
+ --disable-libfuzzer # Should not be used normally according to upstream
+ --without-libblkio # Not in Gentoo.
+ --without-bash-completions # Handled manually.
+
+ # TODO(arsen): Bindings left out
+ --disable-perl
+ # salahx: Add python support
+ $(use_enable python)
+ --disable-ocaml
+ --disable-rust
+ --disable-tcl
+ --disable-lua
+ --disable-golang
+
+ # This just enabled a few code paths with no extra library
+ # dependencies, but it does have an extra xorriso runtime
+ # dependency. Seeing as it's optional, and it conflates BDEPEND
+ # and RDEPEND; I think it's okay to just specify that it uses
+ # XORRISO installed as xorriso. Maybe the user should be able
+ # to override this in the future if they prefer one of the other
+ # ISOPROGs?
+ --with-iso
+ ac_cv_prog_XORRISO=xorriso
+
+ # Involves proprietary code and a dlopen mess, see
+ # plugins/vddk/README.VDDK.
+ --disable-vddk
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+ dobashcomp bash-completion/nbdkit
+}
+
+pkg_postinst() {
+ optfeature "virtual ISO plugin via xorriso" dev-libs/libisoburn
+ if use python; then
+ optfeature "Amazon S3 support" dev-python/boto3
+ fi
+}