summaryrefslogtreecommitdiff
path: root/sys-block/whdd/whdd-2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/whdd/whdd-2.2.ebuild')
-rw-r--r--sys-block/whdd/whdd-2.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-block/whdd/whdd-2.2.ebuild b/sys-block/whdd/whdd-2.2.ebuild
new file mode 100644
index 000000000000..170ff794a99e
--- /dev/null
+++ b/sys-block/whdd/whdd-2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Diagnostic and recovery tool for block devices"
+HOMEPAGE="https://whdd.github.io"
+SRC_URI="https://github.com/krieger-od/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-util/dialog
+ sys-libs/ncurses:0[unicode]"
+RDEPEND="${DEPEND}
+ sys-apps/smartmontools"
+
+src_unpack() {
+ default
+ mv krieger-od-${PN}-* ${P}
+ echo ${PV} > "${S}"/VERSION || die
+}