summaryrefslogtreecommitdiff
path: root/sys-block
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/Manifest.gzbin10530 -> 10524 bytes
-rw-r--r--sys-block/arcconf/Manifest2
-rw-r--r--sys-block/arcconf/arcconf-3.07.23971.ebuild35
-rw-r--r--sys-block/blktrace/Manifest5
-rw-r--r--sys-block/blktrace/blktrace-1.2.0.ebuild53
-rw-r--r--sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch89
-rw-r--r--sys-block/blktrace/files/blktrace-1.2.0-overlapping-io-stats.patch68
-rw-r--r--sys-block/blktrace/files/blktrace-1.2.0-parallel-build.patch71
-rw-r--r--sys-block/fio/Manifest2
-rw-r--r--sys-block/fio/fio-3.27.ebuild2
-rw-r--r--sys-block/partitionmanager/Manifest2
-rw-r--r--sys-block/partitionmanager/partitionmanager-21.04.3.ebuild36
12 files changed, 77 insertions, 288 deletions
diff --git a/sys-block/Manifest.gz b/sys-block/Manifest.gz
index ee8eb968f827..9e4a7561c50f 100644
--- a/sys-block/Manifest.gz
+++ b/sys-block/Manifest.gz
Binary files differ
diff --git a/sys-block/arcconf/Manifest b/sys-block/arcconf/Manifest
index 485195ac2d85..3b039cf0b01f 100644
--- a/sys-block/arcconf/Manifest
+++ b/sys-block/arcconf/Manifest
@@ -1,5 +1,7 @@
DIST arcconf_v2_01_22270.zip 47168976 BLAKE2B 95693a1408e5a4d0d638bbf265f2e1e64247dfec2b1078b56860c5fcd4b13ffa5967bfb9967abfd4b79c788aaeb20759b3a9070a84b083c1653e4868a96ac4cf SHA512 0f91a697c44ea0c0561bec9e432e7d4eba8eb8a2b0255a9867bdb183f81e745aee1dcc2b0017847803dbb27f55cad3e985f4bcd3a202c52f5b557fb724e94d9e
DIST arcconf_v3_04_23731.zip 95891681 BLAKE2B e2e001ba8c720a98ad26d46006e27597c9819c815d3ec123708261f771e67991cc460e267e7ccca661c5ab061fea5296f1d49b7374a66a8340617654aea525ae SHA512 800f3c0ecd0d3095c34f787a2ce52ee7424de9bd810040b7bee6096cb9cd07464012c383fe63a9dbf9161112f67ab159890fc63960eb436ce2685a5e28d4182f
+DIST arcconf_v3_07_23971.zip 99777386 BLAKE2B 2fa5e5af1148d1aa67281af927cc9e158f85ffadcd49158adcd9dbb36b1a2c7b7607e68f44b5d2dc1e0ca80d7a0d64c447b93cffa048a03438a4473fefdc06e6 SHA512 09fc72931471c146ad6d5261efe15e2ede24198a16e554cc916bc30e775f592bd9ee476aaacace4df51504580aba03c52b30f5ebb133b410bddec3ccb330fddb
EBUILD arcconf-2.01.22270-r1.ebuild 976 BLAKE2B 32a256f22700c1942507efc92a5952db4bc48e155a9e4e1d0cb8257c1e6ed3f382d0e6266f47d7d798f95c6e7a40cc1ec0b59efd3e0b4ae051a3df84202954c2 SHA512 495ba77e23fe276ab404643559194c71f29e891afab5613da69ecec857d741a21d0410e2a48044fb39da7b5bbb0e2f912c21002d993578aebef9e7b39bf43f8f
EBUILD arcconf-3.04.23731.ebuild 939 BLAKE2B cb96aee891a6cc168a2425c9ea3114c28dfa0d5646114419bed9d11637823c94adba93885abb1251dea0336cfdb7869d58632e349255db7ff90b5c8ab65b8ea7 SHA512 556311a56a049e1034812fc4e545f255d14337f6255ee271665b25192a2b6aa34a34342e3e8391657b480826d23a11953f2263c97974a998f9bd4bc8285cf708
+EBUILD arcconf-3.07.23971.ebuild 744 BLAKE2B bf1ed950c574fcd86cbb03e6e41808fe2790f16ff3721a5c915b42d9dac5a3c371b3620268727af9707b67b914974e8e998f6cb38ea31107e9f795746e663697 SHA512 12647c40477cc638e99a405292e348a92efb1b16114961616e50ceb67e599f54a8726a2633750591b9992f710ca6531da6092a42e91c869d3305cca219f936ce
MISC metadata.xml 819 BLAKE2B db0209c49563799b6e71389de7f139c9590406e24272bacd67f667fd544d66aedbf0869d4dc09ca1590601ab0f1a5393a618c408d66e3a447854f0f47df5f99a SHA512 a8e9ba3d80eb67f5ece7d1e1ef4dd7c77da021000daad99fdb191ec59aba378421c6a313a43c13560909fa08e1edbb68baeb700c5a8e012be0f60439a12c6182
diff --git a/sys-block/arcconf/arcconf-3.07.23971.ebuild b/sys-block/arcconf/arcconf-3.07.23971.ebuild
new file mode 100644
index 000000000000..4d619ba2690e
--- /dev/null
+++ b/sys-block/arcconf/arcconf-3.07.23971.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="v${PV//./_}"
+
+inherit linux-info
+
+DESCRIPTION="Microsemi Adaptec RAID Controller Command Line Utility"
+HOMEPAGE="https://www.microsemi.com/"
+SRC_URI="http://download.adaptec.com/raid/storage_manager/${PN}_${MY_PV}.zip"
+S="${WORKDIR}/linux_x64"
+
+LICENSE="Microsemi"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+BDEPEND="app-arch/unzip"
+
+RESTRICT="mirror bindist"
+
+QA_PREBUILT="usr/bin/arcconf"
+
+pkg_setup() {
+ # CONFIG_HARDENED_USERCOPY_PAGESPAN makes ARCCONF segault
+ if linux-info_get_any_version && linux_config_src_exists ; then
+ CONFIG_CHECK="!HARDENED_USERCOPY_PAGESPAN"
+ check_extra_config
+ fi
+}
+
+src_install() {
+ dobin arcconf
+}
diff --git a/sys-block/blktrace/Manifest b/sys-block/blktrace/Manifest
index dbf10c02e14e..a56149aafe9b 100644
--- a/sys-block/blktrace/Manifest
+++ b/sys-block/blktrace/Manifest
@@ -1,8 +1,3 @@
-AUX blktrace-1.2.0-ldflags.patch 2748 BLAKE2B 2e5bb94aeb829d6f187bb22c109f732fd442df20c1da4acc4cb31fff46d51e9dc37f0aa2c2bceac661c334c0f1727214fba4ee22455e4df2a58efb817d9eb1c3 SHA512 d0a411020f7ca01beea5c7915e1d934c93120d86111d789fd2c7719d10b116e56634b86fe5f37717e104c6493bbce2878df2abf9ddea8ba87089cb2f0a01c084
-AUX blktrace-1.2.0-overlapping-io-stats.patch 1973 BLAKE2B 2ba883a033f24b9c3b70bab6f4b1c0843452cb1ec63b5d3efda549b0ff99d01170e43b9bcb8ab9ccb3206792aac7f69bc1b1fee5e39378159d4c30463bc8abc3 SHA512 b72a7f6bb03105e7e10116c70bc79d4fe131f223cf5d56649850f777c59226a8c78d7f0dc758fba97891f2f29bde903e41c7bf5e04cae710058a3e38017c02b7
-AUX blktrace-1.2.0-parallel-build.patch 2300 BLAKE2B 87ff4b31b845aee1fe8f14a8a6d35d08d386969eee05c07b2e1b3de2fa2f039d49d699228ef01793cee935ecea5517c9603956866ac3f677eafbb153f9b5382f SHA512 fbb2b217b73072e408e1bad7e3b663935cb005c4ee5cf3dbb1d02cc17b55b511f5982e108545159d0968e8b6ec759441953fd127ad0beeb8661d51fcf9ba6ca1
-DIST blktrace-1.2.0.tar.bz2 395193 BLAKE2B 8f8505f27985f0451f75ced0e438a88758482227e83ba8de235986ab3f116cf38d5aec340d1e7ce3dc3aa5a97c0bd4c46265687976e7326a54ea2e7cce4afc82 SHA512 ce82c8010ca5c2868746d8eb7c6a107fc7382c05df949eeff79e612f5b1a98301a5aa5ab39de0766ea1c074f95e378ba985401cbeba9a296e3182da7d7a23b86
DIST blktrace-1.3.0.tar.bz2 396669 BLAKE2B ab340b27421ec423c8e5bd9fd719f97e06c30366ce95560adea644d10737f41d2c2f16e4c6503b65ef8fedeec7d997de6f47f0d3f2542c5065fe7846f8d18966 SHA512 4cc3d8e0d77e934bd70f447e1bb462400d3c9982460802f093d260e3cb69a66c6f61a63a05af55b84c35c5bdf18027e571d55cebea8c89d0be6d00c7ca9b9174
-EBUILD blktrace-1.2.0.ebuild 1370 BLAKE2B 9f79673ec496b7e8a5373af3ee2d53e44c306de91a45d74c11d6c5a92def87ac22cb50294aa1971f914e7c6923cfe5e619b18e3565639e8fb8de8ab777d9055a SHA512 3b48df771890b653872add3533114dead2ba9eac4d1f46aa935ecf6b691a4771da036f57aad4f5b9a5803e5584676d9cf5c889360e340b1e5eed966a47c70acf
EBUILD blktrace-1.3.0.ebuild 1560 BLAKE2B 9324cbb84ca1a955f66784d9b96d27dd07874f20f1fbfd8199dff2d883c93571b956c72ad88d949ff6a703cddef4cef4c8df6fbf6479035c14d364fabaff0e6d SHA512 23091b6e6f1dfd40f1ff0a06c74b4428adc34a78d17d7ea67c223cc3d71734505e390fe1db4678591f53cddcc09570e81519d36ba93fd3578faa7215af791512
MISC metadata.xml 216 BLAKE2B 20531789dc11e43feee7ec315a0c1c7249fdf73764e29cb7d6db439826e9ff72f24a5cdb8eb7f1ab99bbb41fb6e4226874a1d1fa4185de52598602bb3b0479a3 SHA512 e881b59fe49746eb25ad66c258b41aba501e4eb563129093a3898ea970a20506e7898f7c355cfcf99605234962bf2c77c1309c258b9a2b84ee4302ccb71c9dbd
diff --git a/sys-block/blktrace/blktrace-1.2.0.ebuild b/sys-block/blktrace/blktrace-1.2.0.ebuild
deleted file mode 100644
index ee5ebdfdceb7..000000000000
--- a/sys-block/blktrace/blktrace-1.2.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit toolchain-funcs flag-o-matic linux-info
-
-MY_PN="blktrace"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="show detailed info about what is happening on a block device io queue"
-HOMEPAGE="https://git.kernel.dk/cgit/blktrace/"
-SRC_URI="https://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc x86"
-IUSE="doc"
-
-RDEPEND="dev-libs/libaio"
-# This is a Linux specific app!
-DEPEND="${RDEPEND}
- sys-kernel/linux-headers
- doc? (
- virtual/latex-base
- >=app-text/texlive-core-2014
- )
-"
-S="${WORKDIR}/${MY_P}"
-
-CONFIG_CHECK="~BLK_DEV_IO_TRACE"
-WARNING_BLK_DEV_IO_TRACE="you need to enable BLK_DEV_IO_TRACE kernel option if you want to gather traces from this machine"
-
-PATCHES=(
- "${FILESDIR}"/${P}-overlapping-io-stats.patch
- "${FILESDIR}"/${PN}-1.2.0-ldflags.patch #335741
- "${FILESDIR}"/${PN}-1.2.0-parallel-build.patch #335741
-)
-
-src_compile() {
- append-cppflags -DLVM_REMAP_WORKAROUND -W -I"${S}"
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS}"
- if use doc; then
- export VARTEXFONTS="${T}/fonts"
- emake docs
- fi
-}
-
-src_install() {
- emake install CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS}" DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man"
- einstalldocs
- use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
-}
diff --git a/sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch b/sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch
deleted file mode 100644
index b8e2aebfff4f..000000000000
--- a/sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-http://git.kernel.dk/?p=blktrace.git;a=commit;h=d1398e339585f6750f7158c50c98861b68dddc8b
-
-From 6d8c3d7a10f62b26514a56b25a3744c5f35219a6 Mon Sep 17 00:00:00 2001
-From: "Robin H. Johnson" <robbat2@gentoo.org>
-Date: Tue, 23 Jan 2018 17:40:48 -0500
-Subject: [PATCH] respect LDFLAGS when linking programs
-
----
- Makefile | 10 +++++-----
- btreplay/Makefile | 4 ++--
- btt/Makefile | 2 +-
- iowatcher/Makefile | 2 +-
- 4 files changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index fdbded02ee0a..68de59183a73 100644
---- a/Makefile
-+++ b/Makefile
-@@ -26,19 +26,19 @@ btreplay/btreplay:
- $(CC) -o $*.o -c $(ALL_CFLAGS) $<
-
- blkparse: blkparse.o blkparse_fmt.o rbtree.o act_mask.o
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
-+ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
-
- blktrace: blktrace.o act_mask.o
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-+ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-
- verify_blkparse: verify_blkparse.o
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
-+ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
-
- blkrawverify: blkrawverify.o
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
-+ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
-
- blkiomon: blkiomon.o rbtree.o
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) -lrt
-+ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS) -lrt
-
- $(PROGS): | depend
-
-diff --git a/btreplay/Makefile b/btreplay/Makefile
-index 2998182401e7..f574a2976ec1 100644
---- a/btreplay/Makefile
-+++ b/btreplay/Makefile
-@@ -32,10 +32,10 @@ clean: docsclean
- $(CC) $(CFLAGS) -c -o $*.o $<
-
- btrecord: btrecord.o
-- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
-
- btreplay: btreplay.o
-- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-
- depend:
- @$(CC) -MM $(CFLAGS) *.c 1> .depend
-diff --git a/btt/Makefile b/btt/Makefile
-index df7a3de6b3fb..32075573954c 100644
---- a/btt/Makefile
-+++ b/btt/Makefile
-@@ -38,7 +38,7 @@ clean: docsclean
- $(CC) $(CFLAGS) -c -o $*.o $<
-
- btt: $(OBJS)
-- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-
- ifneq ($(wildcard .depend),)
- include .depend
-diff --git a/iowatcher/Makefile b/iowatcher/Makefile
-index e013556f3ae1..a224a0848cc8 100644
---- a/iowatcher/Makefile
-+++ b/iowatcher/Makefile
-@@ -19,7 +19,7 @@ all: $(ALL)
- $(CC) -o $*.o -c $(ALL_CFLAGS) $<
-
- iowatcher: blkparse.o plot.o main.o tracers.o mpstat.o fio.o
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) -lm -lrt
-+ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) -lm -lrt
-
- depend:
- @$(CC) -MM $(ALL_CFLAGS) *.c 1> .depend
---
-2.15.1
-
diff --git a/sys-block/blktrace/files/blktrace-1.2.0-overlapping-io-stats.patch b/sys-block/blktrace/files/blktrace-1.2.0-overlapping-io-stats.patch
deleted file mode 100644
index 11c495efbc0c..000000000000
--- a/sys-block/blktrace/files/blktrace-1.2.0-overlapping-io-stats.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-http://git.kernel.dk/?p=blktrace.git;a=commit;h=8fc451c6b0b9a7db7c376ea6865c35321e561f00
-
-From 8fc451c6b0b9a7db7c376ea6865c35321e561f00 Mon Sep 17 00:00:00 2001
-From: Gwendal Grignou <gwendal@chromium.org>
-Date: Fri, 18 Aug 2017 15:00:22 -0700
-Subject: [PATCH] btt: Fix overlapping IO stats.
-
-Keep scanning the tree for overlapping IO otherwise Q2G and process
-traces will be incorrect.
-
-Let assume we have 2 IOs:
-
-A A+a
-|---------------------------------------|
- B B+b
- |-----------------|
-
-In the red/black tree we have:
-
- o -> [A,A+a]
- / \
- left right
- / \
- [...]o o -> [B, B+b]
-
-In the current code, if we would not be able to find [B+b] in the tree:
-B is greater than A, so we won't go left
-B+b is smaller than A+a, so we are not going right either.
-
-When we have a [X, X+x] IO to look for:
-We need to check for right when either:
- X+x >= A+a (for merged IO)
-and
- X > A (for overlapping IO)
-
-TEST=Check with a trace with overlapping IO: Q2C and Q2G are expected.
-
-Signed-off-by: Gwendal Grignou <gwendal@chromium.org>
-Signed-off-by: Jens Axboe <axboe@kernel.dk>
----
- btt/dip_rb.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/btt/dip_rb.c b/btt/dip_rb.c
-index 2aa7ffcc763b..6efef6c03b8f 100644
---- a/btt/dip_rb.c
-+++ b/btt/dip_rb.c
-@@ -57,7 +57,7 @@ struct io *rb_find_sec(struct rb_root *root, __u64 sec)
- __iop = rb_entry(n, struct io, rb_node);
- if (sec < BIT_START(__iop))
- n = n->rb_left;
-- else if (sec >= BIT_END(__iop))
-+ else if (sec > BIT_START(__iop))
- n = n->rb_right;
- else
- return __iop;
-@@ -82,7 +82,7 @@ void rb_foreach(struct rb_node *n, struct io *iop,
- }
- if (iop_s < this_s)
- rb_foreach(n->rb_left, iop, fnc, head);
-- if (this_e < iop_e)
-+ if ((this_e < iop_e) || (this_s < iop_s))
- rb_foreach(n->rb_right, iop, fnc, head);
- }
- }
---
-2.15.1
-
diff --git a/sys-block/blktrace/files/blktrace-1.2.0-parallel-build.patch b/sys-block/blktrace/files/blktrace-1.2.0-parallel-build.patch
deleted file mode 100644
index 129f04107fa1..000000000000
--- a/sys-block/blktrace/files/blktrace-1.2.0-parallel-build.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-http://git.kernel.dk/?p=blktrace.git;a=commit;h=519fd9a5d08d85f3d9cb4192d624fe8351e40232
-
-From 4569544261be495bdec0574d7729c85a62dabad7 Mon Sep 17 00:00:00 2001
-From: "Robin H. Johnson" <robbat2@gentoo.org>
-Date: Thu, 3 Feb 2011 03:07:06 +0000
-Subject: [PATCH] fix parallel build failures
-
-When building in parallel, the btreplay/btrecord and btreplay/btreplay
-targets cause make to kick off two jobs for `make -C btreplay` and they
-sometimes end up clobbering each other. We could fix this by making one
-a dependency of the other, but it's a bit cleaner to refactor things to
-be based on subdirs. This way changes in subdirs also get noticed:
- $ touch btreplay/*.[ch]
- $ make
- <btreplay is now correctly updated>
-
-Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-Signed-off-by: Mike Frysinger <vapier@gentoo.org>
----
- Makefile | 24 ++++++++++--------------
- 1 file changed, 10 insertions(+), 14 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 68de59183a73..5917814d0344 100644
---- a/Makefile
-+++ b/Makefile
-@@ -4,23 +4,19 @@ ALL_CFLAGS = $(CFLAGS) -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
- PROGS = blkparse blktrace verify_blkparse blkrawverify blkiomon
- LIBS = -lpthread
- SCRIPTS = btrace
-+SUBDIRS = btreplay btt iowatcher
-
--ALL = $(PROGS) $(SCRIPTS) btt/btt btreplay/btrecord btreplay/btreplay \
-+ALL = $(PROGS) $(SCRIPTS)
-+INSTALL_ALL = $(ALL) btt/btt btreplay/btrecord btreplay/btreplay \
- btt/bno_plot.py iowatcher/iowatcher
-
--all: $(ALL)
-+all: $(ALL) $(SUBDIRS)
-
--btt/btt:
-- $(MAKE) -C btt
--
--iowatcher/iowatcher:
-- $(MAKE) -C iowatcher
--
--btreplay/btrecord:
-- $(MAKE) -C btreplay
--
--btreplay/btreplay:
-- $(MAKE) -C btreplay
-+# We always descend into subdirs because they contain their own dependency
-+# information which we don't track in this top level Makefile.
-+$(SUBDIRS):
-+ $(MAKE) -C $@
-+.PHONY: $(SUBDIRS)
-
- %.o: %.c
- $(CC) -o $*.o -c $(ALL_CFLAGS) $<
-@@ -85,7 +81,7 @@ install: all
- $(INSTALL) -m 755 -d $(DESTDIR)$(bindir)
- $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1
- $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man8
-- $(INSTALL) -m 755 $(ALL) $(DESTDIR)$(bindir)
-+ $(INSTALL) -m 755 $(INSTALL_ALL) $(DESTDIR)$(bindir)
- $(INSTALL) -m 644 doc/*.1 $(DESTDIR)$(mandir)/man1
- $(INSTALL) -m 644 doc/*.8 $(DESTDIR)$(mandir)/man8
-
---
-2.15.1
-
diff --git a/sys-block/fio/Manifest b/sys-block/fio/Manifest
index b9b66811e958..798f54f4a8c5 100644
--- a/sys-block/fio/Manifest
+++ b/sys-block/fio/Manifest
@@ -3,5 +3,5 @@ AUX fio-3.20-fno-common.patch 1220 BLAKE2B dcfaac74241111cae75ebf956f34258ce883b
DIST fio-3.20.tar.bz2 912040 BLAKE2B 44f8c20a390a6382aadc07881c1e7c65cca932099a1b3992e848669cf2a52b410fde67f9ae576efcd0d8e88ceec04174b6bc077d4b3f9b615b59be9f24f62bed SHA512 4e073754c95cb8d6416a80f48ca61003f34d664717f67a3f29b554e9205f8fe3553595ba6f8a8e9cb3463022d5c83be961f5b5a1ebcd2a9f4da9406a9986c1fb
DIST fio-3.27.tar.bz2 960330 BLAKE2B 7e7e01a5c1d6af13a6f87139e7738646cbc8f45ebc370d0c45b9efe1f93778613d374daafc6df459f988f27f2be54ff636235e1e5a92a4a6ecf9a60ed573d170 SHA512 9c5f2ab0c9ac24ab78dbc74fb6c5acd60f8189fdc618f4280992141b6c0abe1c235c373fee18ad0c803e7fb25d480f45aec56dc3be2e0d26d181b3418b179f99
EBUILD fio-3.20-r2.ebuild 4337 BLAKE2B cad2afe783c27e7e55fa8884d5fd8725ebf6f7900319970d7f837a999bc461e2cc8e882a7c86bdaeab3b60ecb07f11a2f1344122bcd0398e91602cf2852652c3 SHA512 b36adb5fa50b176031a63d4aa06bcf4bf2740b1daac62ddecdb542f437c03e858e43e332636eabcf9d3bf47c69e2e2192ee4549de95fded13a96aa48c03cc2a8
-EBUILD fio-3.27.ebuild 4253 BLAKE2B 6aa36fb2d9a8430f39f3cd1da138449c529607520c5a0654f60d9c0c300f7a75a3e74fc08d03e03f049e73d09c14e797a0af36086595c3ed579dad464e15fe73 SHA512 c3949d3d842983a82e8c3587a0a53353de8c5a349a1eabbb23b3ab91be0e3912fbce55a23034c3619c64a73f7f128396070a2c29c4f8f646386bae93c792b746
+EBUILD fio-3.27.ebuild 4248 BLAKE2B 3ce690dfcc7de7f55325128cd8e51d04b80226e8cdcf3811739b5dc4098b26894b4be622d45d05dc3966bb07e0692ff565699b44592e4cbf44ee134c3541bea4 SHA512 6202649f094e30df45cd9e40080c6dede7bf9ea59e69d91fb236c504c045c6e74f357569b2579d048a8f50b759ab26cdf545229c328607c5d89a416a9b1d792e
MISC metadata.xml 1172 BLAKE2B e35bbaaa15c8cd095791a4a23a7344314a015ea42bb864b11bb165d340585ee667f969426282465b834a7d092ab6885736e55ec8d4fe950001fbb6336fdfdc14 SHA512 defbc7f932a5ab83b67da58a601ef62784b27f2268f8a8dd5057c02fb441b164bd0945217fa52a0e06803c74b5168dda3b4668de52f593d5cade428bd2f79e86
diff --git a/sys-block/fio/fio-3.27.ebuild b/sys-block/fio/fio-3.27.ebuild
index 2a78e187bb6a..1a61f8f61665 100644
--- a/sys-block/fio/fio-3.27.ebuild
+++ b/sys-block/fio/fio-3.27.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 arm ~arm64 ~ia64 ppc ppc64 x86"
IUSE="aio curl glusterfs gnuplot gtk io-uring numa python rbd rdma static tcmalloc test zbc zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
gnuplot? ( python )
diff --git a/sys-block/partitionmanager/Manifest b/sys-block/partitionmanager/Manifest
index 8ee7f6b25916..4c605a61c7fa 100644
--- a/sys-block/partitionmanager/Manifest
+++ b/sys-block/partitionmanager/Manifest
@@ -1,5 +1,7 @@
DIST partitionmanager-20.12.3.tar.xz 2085060 BLAKE2B b6f94220f157e33d287f967d0ed568b07622cdbedda82e2659257b92487a40cc8519922f62c705b9eefca5404c0f43b6b331679fd4b18fb5957bbc850417c296 SHA512 480f706b3c1fd7fcd3df49bf9f2277a4337ca696e912664fa9283110be2575b84694b1145d02bf9c4c968ea1be1864c01125e9fe3892d910b898a4afb2aac130
DIST partitionmanager-21.04.2.tar.xz 2097448 BLAKE2B e84e99f7eb4cec2394835fcca7dab81c04418588d07b7d93f434528c2882236b2f9a7b7ed94992e1142b31d59de589f669f862938c9b6d8d7950e5f2e1d66ebf SHA512 6e4437810b1cf24872f7a16a2abfc9b2a2426b14cae10563a0917eae15b04d7cae27d2df7137112d79a89fa27cd9a57ddc0a77d085945436a47e9910fc462054
+DIST partitionmanager-21.04.3.tar.xz 2097428 BLAKE2B 821ea6c8cd61a250acd433e55dddc3ddc6e115f8908f79b7d243e0ba5bda69f8edc38e6b2aef1d014258d38111b8cdd361632015af031fd85ced9d13f3ba6129 SHA512 cfaf08ee27a4976de38cee282092915aa154a3c4c0561b1ce9a971e991038473dcce4ffd4f20d845eb5d29e48a223f16b3d4a670d0442b8267c4ed0c86dff4a4
EBUILD partitionmanager-20.12.3.ebuild 941 BLAKE2B ffa89f5fcebe8b912f97b879fb36d1e7998660366b9b19a81dd7cc860e51419a532b0415be587d090af24d02aad8d5b32c98e159001fec2d32873806d284d7a0 SHA512 eebc080000ac20184cfa03e78c7be88d14e3a701e8cdd1f85eb50ebc67192628408c2f79d23e0facb4488064bfd7be62393a6bf03e97a98e7045a3d18ac544d9
EBUILD partitionmanager-21.04.2.ebuild 933 BLAKE2B 875a518c404bf5ff689394cdf27b42dc55f6fb76578232f9f59a11654e680aa26aeec85c265174302e237cf855d433e9359db5898f3ec78609927775376c410e SHA512 656821a719b0f638437414b6e62a4b7e8d9233392ace32ece4fea3a075a0ff2a9cef1614977e6e16baa4ef317bf7bf2985dad467c65086ce89b758b51d1c8606
+EBUILD partitionmanager-21.04.3.ebuild 933 BLAKE2B 875a518c404bf5ff689394cdf27b42dc55f6fb76578232f9f59a11654e680aa26aeec85c265174302e237cf855d433e9359db5898f3ec78609927775376c410e SHA512 656821a719b0f638437414b6e62a4b7e8d9233392ace32ece4fea3a075a0ff2a9cef1614977e6e16baa4ef317bf7bf2985dad467c65086ce89b758b51d1c8606
MISC metadata.xml 249 BLAKE2B ad415db89e5dee1627aa77f44ded9d4e1e5b8217d06c7ca25bbaa3fe92ce67c2b1090957c45a821b407d7927e5af798498aa6a5b903895ee1af8ee20a446c7f7 SHA512 76a5a340b13f0053ca3c5e94ed24380ea8d29b45ac8655419e22eaadb1e4a827c04d2e7e36b65145c4964e6526f656618fc6ac144e277ef53cb7373e6239e3c3
diff --git a/sys-block/partitionmanager/partitionmanager-21.04.3.ebuild b/sys-block/partitionmanager/partitionmanager-21.04.3.ebuild
new file mode 100644
index 000000000000..c53fb9a3e278
--- /dev/null
+++ b/sys-block/partitionmanager/partitionmanager-21.04.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="optional"
+KDE_GEAR="true"
+KFMIN=5.80.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Utility for management of disks, partitions and file systems"
+HOMEPAGE="https://apps.kde.org/partitionmanager/"
+
+LICENSE="GPL-3"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=sys-libs/kpmcore-${PVCUT}:5=
+"
+RDEPEND="${DEPEND}"