summaryrefslogtreecommitdiff
path: root/sys-boot/palo/palo-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/palo/palo-9999.ebuild')
-rw-r--r--sys-boot/palo/palo-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-boot/palo/palo-9999.ebuild b/sys-boot/palo/palo-9999.ebuild
new file mode 100644
index 000000000000..2d47d63af700
--- /dev/null
+++ b/sys-boot/palo/palo-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic git-r3 toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/deller/palo.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9999-toolchain.patch
+)
+
+src_prepare() {
+ default
+ sed -i lib/common.h -e '/^#define PALOVERSION/{s|".*"|"'${PV}'"|g}' || die
+}
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ doman palo.8
+ dodoc TODO debian/changelog README.html
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc/kernel/postinst.d/
+ insopts -m 0744
+ doins "${FILESDIR}"/99palo
+}