summaryrefslogtreecommitdiff
path: root/sys-cluster/ceph/files/ceph-12.2.12-ncurses-tinfo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/ceph/files/ceph-12.2.12-ncurses-tinfo.patch')
-rw-r--r--sys-cluster/ceph/files/ceph-12.2.12-ncurses-tinfo.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/sys-cluster/ceph/files/ceph-12.2.12-ncurses-tinfo.patch b/sys-cluster/ceph/files/ceph-12.2.12-ncurses-tinfo.patch
new file mode 100644
index 000000000000..1b72e5447dbe
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-12.2.12-ncurses-tinfo.patch
@@ -0,0 +1,20 @@
+diff --git a/src/tools/rbd/CMakeLists.txt b/src/tools/rbd/CMakeLists.txt
+index 7aa42e9efd..66186b159f 100644
+--- a/src/tools/rbd/CMakeLists.txt
++++ b/src/tools/rbd/CMakeLists.txt
+@@ -1,3 +1,6 @@
++set(CURSES_NEED_NCURSES TRUE)
++find_package(Curses REQUIRED)
++
+ set(rbd_srcs
+ rbd.cc
+ ArgumentTypes.cc
+@@ -46,7 +49,7 @@ target_link_libraries(rbd librbd librados
+ cls_journal_client cls_rbd_client
+ rbd_types
+ journal
+- ceph-common global
++ ceph-common global ${CURSES_LIBRARIES}
+ ${BLKID_LIBRARIES} ${CMAKE_DL_LIBS})
+ if(WITH_KRBD)
+ target_link_libraries(rbd