summaryrefslogtreecommitdiff
path: root/sys-cluster/openmpi/openmpi-1.4.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/openmpi/openmpi-1.4.5.ebuild')
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.5.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-cluster/openmpi/openmpi-1.4.5.ebuild b/sys-cluster/openmpi/openmpi-1.4.5.ebuild
index 06dc029d76c8..bc2a4450212b 100644
--- a/sys-cluster/openmpi/openmpi-1.4.5.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.5.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
FORTRAN_NEEDED=fortran
-inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
+inherit fortran-2 flag-o-matic toolchain-funcs
MY_P=${P/-mpi}
@@ -17,7 +17,7 @@ LICENSE="BSD"
SLOT="0"
RESTRICT="mpi-threads? ( test )"
-KEYWORDS="~alpha amd64 ia64 ppc ppc64 sparc x86"
+KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86"
IUSE="+cxx fortran heterogeneous ipv6 mpi-threads pbs romio threads vt"
RDEPEND="
pbs? ( sys-cluster/torque )
@@ -50,6 +50,7 @@ pkg_setup() {
}
src_prepare() {
+ default
# Necessary for scalibility, see
# http://www.open-mpi.org/community/lists/users/2008/09/6514.php
if use threads; then
@@ -92,7 +93,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
dodoc README AUTHORS NEWS VERSION
}