summaryrefslogtreecommitdiff
path: root/sys-cluster/rdma-core/rdma-core-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/rdma-core/rdma-core-9999.ebuild')
-rw-r--r--sys-cluster/rdma-core/rdma-core-9999.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/sys-cluster/rdma-core/rdma-core-9999.ebuild b/sys-cluster/rdma-core/rdma-core-9999.ebuild
index a8c381b38698..6d11c3600ccd 100644
--- a/sys-cluster/rdma-core/rdma-core-9999.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
-inherit cmake-utils python-single-r1 udev systemd
+inherit cmake python-single-r1 udev systemd
DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
HOMEPAGE="https://github.com/linux-rdma/rdma-core"
@@ -14,8 +14,8 @@ if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
else
- SRC_URI="https://github.com/linux-rdma/rdma-core/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~hppa ~x86"
+ SRC_URI="https://github.com/linux-rdma/rdma-core/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc x86"
fi
LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
@@ -38,7 +38,7 @@ DEPEND="${COMMON_DEPEND}
)"
RDEPEND="${COMMON_DEPEND}
- !!sys-fabric/infiniband-diags
+ !sys-fabric/infiniband-diags
!sys-fabric/libibverbs
!sys-fabric/librdmacm
!sys-fabric/libibumad
@@ -56,15 +56,17 @@ RDEPEND="${COMMON_DEPEND}
BDEPEND="virtual/pkgconfig"
+PATCHES=( "${FILESDIR}"/optional_pandoc.patch )
+
pkg_setup() {
- python-single-r1_pkg_setup
+ use python && python-single-r1_pkg_setup
}
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_FULL_RUNDIR=/run
+ -DCMAKE_INSTALL_RUNDIR=/run
-DCMAKE_INSTALL_SHAREDSTATEDIR=/var/lib
-DCMAKE_INSTALL_UDEV_RULESDIR="$(get_udevdir)"/rules.d
-DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
@@ -82,16 +84,19 @@ src_configure() {
mycmakeargs+=( -DNO_PYVERBS=ON )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
rm -r "${D}"/etc/{udev,init.d} || die
- newinitd "${FILESDIR}"/ibacm.init ibacm
+ if use neigh; then
+ newinitd "${FILESDIR}"/ibacm.init ibacm
+ fi
+
newinitd "${FILESDIR}"/iwpmd.init iwpmd
newinitd "${FILESDIR}"/srpd.init srpd