summaryrefslogtreecommitdiff
path: root/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang-common/clang-common-17.0.0.9999.ebuild')
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0.9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
index abf3150abbd6..8bca701cfc0b 100644
--- a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
@@ -99,6 +99,8 @@ src_install() {
-fstack-protector-strong
-fPIE
-include "${EPREFIX}/usr/include/gentoo/fortify.h"
+
+ -Wl,-z,relro
EOF
dodir /usr/include/gentoo
@@ -144,6 +146,8 @@ src_install() {
# https://libcxx.llvm.org/UsingLibcxx.html#assertions-mode
# https://libcxx.llvm.org/Hardening.html#using-hardened-mode
-D_LIBCPP_ENABLE_HARDENED_MODE=1
+
+ -Wl,-z,now
EOF
fi