summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-14.0.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-14.0.6-r1.ebuild')
-rw-r--r--sys-devel/llvm/llvm-14.0.6-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-devel/llvm/llvm-14.0.6-r1.ebuild b/sys-devel/llvm/llvm-14.0.6-r1.ebuild
index 722dc92b8505..f21b43b8bd2c 100644
--- a/sys-devel/llvm/llvm-14.0.6-r1.ebuild
+++ b/sys-devel/llvm/llvm-14.0.6-r1.ebuild
@@ -75,11 +75,11 @@ llvm.org_set_globals
python_check_deps() {
use doc || return 0
- has_version -b "dev-python/recommonmark[${PYTHON_USEDEP}]" &&
- has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
+ python_has_version -b "dev-python/recommonmark[${PYTHON_USEDEP}]" &&
+ python_has_version -b "dev-python/sphinx[${PYTHON_USEDEP}]"
}
-check_live_ebuild() {
+check_uptodate() {
local prod_targets=(
$(sed -n -e '/set(LLVM_ALL_TARGETS/,/)/p' CMakeLists.txt \
| tail -n +2 | head -n -1)
@@ -176,8 +176,8 @@ src_prepare() {
# Update config.guess to support more systems
cp "${BROOT}/usr/share/gnuconfig/config.guess" cmake/ || die
- # Verify that the live ebuild is up-to-date
- check_live_ebuild
+ # Verify that the ebuild is up-to-date
+ check_uptodate
llvm.org_src_prepare