summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-17.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-17.0.6.ebuild')
-rw-r--r--sys-devel/llvm/llvm-17.0.6.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-17.0.6.ebuild b/sys-devel/llvm/llvm-17.0.6.ebuild
index 8c476ecc2bc9..9d9cc96939a3 100644
--- a/sys-devel/llvm/llvm-17.0.6.ebuild
+++ b/sys-devel/llvm/llvm-17.0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -377,7 +377,8 @@ multilib_src_configure() {
-DLLVM_ENABLE_EH=ON
-DLLVM_ENABLE_RTTI=ON
-DLLVM_ENABLE_Z3_SOLVER=$(usex z3)
- -DLLVM_ENABLE_ZSTD=$(usex zstd)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
-DLLVM_ENABLE_CURL=$(usex debuginfod)
-DLLVM_ENABLE_HTTPLIB=$(usex debuginfod)