summaryrefslogtreecommitdiff
path: root/sys-devel/llvm/llvm-18.0.0_pre20231215.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-18.0.0_pre20231215.ebuild')
-rw-r--r--sys-devel/llvm/llvm-18.0.0_pre20231215.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-18.0.0_pre20231215.ebuild b/sys-devel/llvm/llvm-18.0.0_pre20231215.ebuild
index 0fe2c5be8d56..c6874626a4e4 100644
--- a/sys-devel/llvm/llvm-18.0.0_pre20231215.ebuild
+++ b/sys-devel/llvm/llvm-18.0.0_pre20231215.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -373,7 +373,8 @@ multilib_src_configure() {
-DLLVM_ENABLE_EH=ON
-DLLVM_ENABLE_RTTI=ON
-DLLVM_ENABLE_Z3_SOLVER=$(usex z3)
- -DLLVM_ENABLE_ZSTD=$(usex zstd)
+ -DLLVM_ENABLE_ZLIB=FORCE_ON
+ -DLLVM_ENABLE_ZSTD=$(usex zstd FORCE_ON OFF)
-DLLVM_ENABLE_CURL=$(usex debuginfod)
-DLLVM_ENABLE_HTTPLIB=$(usex debuginfod)