summaryrefslogtreecommitdiff
path: root/sys-devel/mold/mold-2.30.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/mold/mold-2.30.0.ebuild')
-rw-r--r--sys-devel/mold/mold-2.30.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-devel/mold/mold-2.30.0.ebuild b/sys-devel/mold/mold-2.30.0.ebuild
index a121f5ffefba..05ff0820df78 100644
--- a/sys-devel/mold/mold-2.30.0.ebuild
+++ b/sys-devel/mold/mold-2.30.0.ebuild
@@ -31,6 +31,11 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc14.patch
+ "${FILESDIR}"/${PN}-2.30.0-which-hunt.patch
+)
+
pkg_pretend() {
# Requires a c++20 compiler, see #831473
if [[ ${MERGE_TYPE} != binary ]]; then
@@ -65,7 +70,6 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- -DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON
-DMOLD_ENABLE_QEMU_TESTS=OFF
-DMOLD_LTO=OFF # Should be up to the user to decide this with CXXFLAGS.
-DMOLD_USE_MIMALLOC=$(usex !kernel_Darwin)