summaryrefslogtreecommitdiff
path: root/sys-devel/reflex/reflex-20221012.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/reflex/reflex-20221012.ebuild')
-rw-r--r--sys-devel/reflex/reflex-20221012.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-devel/reflex/reflex-20221012.ebuild b/sys-devel/reflex/reflex-20221012.ebuild
new file mode 100644
index 000000000000..e41fcccb03a9
--- /dev/null
+++ b/sys-devel/reflex/reflex-20221012.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+DESCRIPTION="This is a variant of the flex fast lexical scanner"
+HOMEPAGE="https://invisible-island.net/reflex/"
+SRC_URI="https://invisible-island.net/archives/${PN}/${P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${P}.tgz.asc )"
+
+LICENSE="FLEX"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-thomasdickey )"
+
+src_install() {
+ default
+
+ # Workaround assumption of gzip compressed manpage
+ # Reported upstream via email
+ rm "${ED}"/usr/share/man/man1/reflex++.1.gz || die
+ dosym reflex.1 /usr/share/man/man1/reflex++.1 || die
+}