summaryrefslogtreecommitdiff
path: root/sys-fs/duperemove/duperemove-0.09.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/duperemove/duperemove-0.09.2.ebuild')
-rw-r--r--sys-fs/duperemove/duperemove-0.09.2.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/sys-fs/duperemove/duperemove-0.09.2.ebuild b/sys-fs/duperemove/duperemove-0.09.2.ebuild
deleted file mode 100644
index 36b1db08909f..000000000000
--- a/sys-fs/duperemove/duperemove-0.09.2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Btrfs deduplication utility"
-HOMEPAGE="https://github.com/markfasheh/duperemove"
-SRC_URI="https://github.com/markfasheh/duperemove/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="dev-libs/glib:2=
- dev-libs/libgcrypt:0="
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- # https://github.com/markfasheh/duperemove/issues/53#issuecomment-89796552
- sed -i -e '/glib2_mutex_unlock/s:mutex_lock:mutex_unlock:' duperemove.c || die
-}
-
-src_compile() {
- # CC & CFLAGS are set via = so need to override them
- # LIBRARY_FLAGS are set via += so need to pass them via env
- export LIBRARY_FLAGS="${LDFLAGS}"
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="/usr" install
-}