summaryrefslogtreecommitdiff
path: root/sys-fs/duperemove/duperemove-0.11.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/duperemove/duperemove-0.11.1.ebuild')
-rw-r--r--sys-fs/duperemove/duperemove-0.11.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-fs/duperemove/duperemove-0.11.1.ebuild b/sys-fs/duperemove/duperemove-0.11.1.ebuild
new file mode 100644
index 000000000000..995cb2060b38
--- /dev/null
+++ b/sys-fs/duperemove/duperemove-0.11.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Btrfs deduplication utility"
+HOMEPAGE="https://github.com/markfasheh/duperemove"
+SRC_URI="https://github.com/markfasheh/duperemove/archive/v${PV/_/.}.tar.gz -> ${P/_/.}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P/_/.}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}