summaryrefslogtreecommitdiff
path: root/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/f2fs-tools/f2fs-tools-9999.ebuild')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-9999.ebuild39
1 files changed, 24 insertions, 15 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild b/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild
index bcb10bcc1cb6..3224cc7ec9ff 100644
--- a/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild
+++ b/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild
@@ -1,22 +1,32 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit git-r3 autotools
+inherit autotools
DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
-HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
-EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/${PN}.git"
-EGIT_BRANCH="dev"
+HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/${PN}.git"
+ EGIT_BRANCH="dev"
+else
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~x86"
+fi
LICENSE="GPL-2"
-SLOT="0/9"
+SLOT="0/10"
IUSE="selinux"
RDEPEND="
+ app-arch/lz4:=
+ dev-libs/lzo:2
+ sys-apps/util-linux
selinux? ( sys-libs/libselinux )
- elibc_musl? ( sys-libs/queue-standalone )"
+ elibc_musl? ( sys-libs/queue-standalone )
+"
DEPEND="${RDEPEND}"
src_prepare() {
@@ -25,17 +35,16 @@ src_prepare() {
}
src_configure() {
- # This is required to install to /sbin, bug #481110
- econf \
- --bindir="${EPREFIX}"/sbin \
- --disable-static \
+ local myconf=(
+ # This is required to install to /sbin, bug #481110
+ --bindir="${EPREFIX}"/sbin
$(use_with selinux)
+ )
+
+ econf "${myconf[@]}"
}
src_install() {
default
- find "${D}" -name "*.la" -delete || die
- # Collides with sg3_utils
- # https://bugs.gentoo.org/880899
- rm "${ED}/usr/sbin/sg_write_buffer" || die
+ find "${ED}" -name "*.la" -delete || die
}