summaryrefslogtreecommitdiff
path: root/sys-fs/f2fs-tools
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/f2fs-tools')
-rw-r--r--sys-fs/f2fs-tools/Manifest2
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.16.0-r2.ebuild62
-rw-r--r--sys-fs/f2fs-tools/files/f2fs-tools-1.16.0-c23.patch41
3 files changed, 105 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/Manifest b/sys-fs/f2fs-tools/Manifest
index 65af86a2102d..07bf2ee9288b 100644
--- a/sys-fs/f2fs-tools/Manifest
+++ b/sys-fs/f2fs-tools/Manifest
@@ -1,5 +1,7 @@
+AUX f2fs-tools-1.16.0-c23.patch 1121 BLAKE2B c80d9a8e8c32bd4ad051d14517ba175e4fb9cfdf5b7f0f17a3f008acb4568ec889a7fcfda904325279af5e8403d8bad40b505ecc0b8b1e2b5f62db2ce70cc170 SHA512 8b9c13fe28e4b34952eff7bc3c702bb5cce049727985f7ca34f1252182472134d8474e5840b9775da240017cc50f6b2b1c2e45d819ec5c486451f7e66f68bc43
AUX f2fs-tools-1.16.0-musl-1.2.4-lfs.patch 11468 BLAKE2B e7149c9c895c108cd90b729e5201fd41aa2a12ff3d4fcc13709015fdc8529f8af5e1d4380966096e4f7a425341d7b1056348b4cc3e35dd113875b882b70a3179 SHA512 05619636cdbb1c602953eee5073c06295adcbe52cca0f57449937ff7b1d96e3c61e3f436858a70399cf4d615b7e8ead21ee71d1a031d481d705e045dd8820dfc
DIST f2fs-tools-1.16.0.tar.gz 265507 BLAKE2B a4fb94ff879198652a2922a0101b7e34aad156c3536e5a20c1cb2e36a6a734d92d3f97b2570eb702d029ef1d6c03d6123113fc1aa5658ba979401e0691b7b447 SHA512 ea198cebf7c5bb0c42c9b53bc80484495c403b1ed1354eb7cb7b4f63ed9a5c81653a76eaf1bc35067171fa5fd99b1564178c5440c21b6b025f4e83b9def82680
EBUILD f2fs-tools-1.16.0-r1.ebuild 1364 BLAKE2B 2f87c56f4b11fc5d80d51d2bcd774cc5f89f0006b5211755e2b2d2a9d7ef54d6429de46384d9454440181edf9e9c39714b8a86d96dc9e3be709edf9aa0c0115b SHA512 6d9f23fc4a8772cacd87d78cc2b7ef9721fb7295d83b0cdda4d71052b5fafadc521a0afa7057ef2c37cf08713c8c58118bbd3ac2e21df2abfea14722c0a805cc
+EBUILD f2fs-tools-1.16.0-r2.ebuild 1400 BLAKE2B ec82c9f0ef4d361c128f03fec7a0b0087a802c02860d9ea9b8eda097828a58eeb863d86f3893c0188b819ee9aedfddc2eafcd6c158fb75b3a1de6d3b316533ec SHA512 f5164f1f8b900c98a5423580c063c6c35dd916357f279a560e616a6ec08a3868e7a92ae09ed769a39b20dec534cd3e9235ee4b1369cc748db92a5390e38e69b2
EBUILD f2fs-tools-9999.ebuild 1316 BLAKE2B 4358f01069ef77b3f41e139ae8cc5ad98507ed4302837f797b5856a1a96e1e873092e7f102fd98bfdff67d8caa67885c73a906e61619855bfa0a8968a87b0f55 SHA512 49ec6a4cc420d13d6c3a3aa8101a2381df02a6a3abde4f7b1b1399381f419c078575f25e6fa6ea8dadfa3efa8dd490bc04d03dc82d6eb91336991af0c4836068
MISC metadata.xml 578 BLAKE2B 3469a97d49d3ec8755c1fb237d022b67678d43bcf8c3b0276de6c0157c880838c0fc8427a5648f7c415f41b1105f915d443debdd92397f8e557c993eeb52be57 SHA512 5414e9f3cfc90e16de569f267802721f6bb8bc324c4174cac4b81bee7fc298876f221360a264a4f0d83ed1ef9f6a336af73fc75eaf0b5203a219d4abea5a23dd
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.16.0-r2.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.16.0-r2.ebuild
new file mode 100644
index 000000000000..68457da3ba7e
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.16.0-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/${PN}.git"
+ EGIT_BRANCH="dev"
+else
+ SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/${PN}.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/10"
+IUSE="lz4 lzo selinux"
+
+RDEPEND="
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:2 )
+ sys-apps/util-linux
+ selinux? ( sys-libs/libselinux )
+ elibc_musl? ( sys-libs/queue-standalone )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-1.2.4-lfs.patch
+ "${FILESDIR}"/${P}-c23.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/863896
+ # Sent an email to linux-f2fs-devel@ but it hasn't been accepted yet...
+ filter-lto
+
+ local myconf=(
+ # This is required to install to /sbin, bug #481110
+ --bindir="${EPREFIX}"/sbin
+ $(use_with lz4)
+ $(use_with lzo lzo2)
+ $(use_with selinux)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}
diff --git a/sys-fs/f2fs-tools/files/f2fs-tools-1.16.0-c23.patch b/sys-fs/f2fs-tools/files/f2fs-tools-1.16.0-c23.patch
new file mode 100644
index 000000000000..272a6bf81b28
--- /dev/null
+++ b/sys-fs/f2fs-tools/files/f2fs-tools-1.16.0-c23.patch
@@ -0,0 +1,41 @@
+https://bugs.gentoo.org/944297
+https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/commit/?id=6617d15a660becc23825007ab3fc2d270b5b250f
+
+From 6617d15a660becc23825007ab3fc2d270b5b250f Mon Sep 17 00:00:00 2001
+From: Jaegeuk Kim <jaegeuk@kernel.org>
+Date: Thu, 24 Oct 2024 20:33:38 +0000
+Subject: f2fs-tools: use stdbool.h instead of bool
+
+The existing bool definition is broken for c23, where bool is now a keyword.
+
+Signed-off-by: Elliott Hughes <enh@google.com>
+Signed-off-by: Jaegeuk Kim <jaegeuk@kernel.org>
+---
+ include/f2fs_fs.h | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/include/f2fs_fs.h b/include/f2fs_fs.h
+index 9534da9..0cb9228 100644
+--- a/include/f2fs_fs.h
++++ b/include/f2fs_fs.h
+@@ -28,6 +28,7 @@
+ #include <stddef.h>
+ #include <string.h>
+ #include <time.h>
++#include <stdbool.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+@@ -119,9 +120,6 @@ typedef uint16_t u16;
+ typedef uint8_t u8;
+ typedef u32 block_t;
+ typedef u32 nid_t;
+-#ifndef bool
+-typedef u8 bool;
+-#endif
+ typedef unsigned long pgoff_t;
+ typedef unsigned short umode_t;
+
+--
+cgit 1.2.3-korg
+