summaryrefslogtreecommitdiff
path: root/sys-fs/lvm2/lvm2-2.03.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/lvm2/lvm2-2.03.16.ebuild')
-rw-r--r--sys-fs/lvm2/lvm2-2.03.16.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/sys-fs/lvm2/lvm2-2.03.16.ebuild b/sys-fs/lvm2/lvm2-2.03.16.ebuild
index 30a41a0a959c..d3922e5152cf 100644
--- a/sys-fs/lvm2/lvm2-2.03.16.ebuild
+++ b/sys-fs/lvm2/lvm2-2.03.16.ebuild
@@ -69,6 +69,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.03.14-r1-fopen-to-freopen.patch
"${FILESDIR}"/${PN}-2.03.14-r1-mallinfo.patch
"${FILESDIR}"/${PN}-2.03.14-freopen_n2.patch
+ "${FILESDIR}"/${PN}-2.03.16-readelf.patch
)
pkg_setup() {
@@ -162,6 +163,7 @@ src_configure() {
myeconfargs+=( --with-thin=none --with-cache=none )
fi
+ export READELF="$(tc-getREADELF)"
myeconfargs+=(
$(use_enable readline)
$(use_enable selinux)
@@ -184,6 +186,7 @@ src_configure() {
$(use_enable systemd notify-dbus)
--with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
CLDFLAGS="${LDFLAGS}"
+ READELF="${READELF}"
)
# Hard-wire this to bash as some shells (dash) don't know
# "-o pipefail" #682404