summaryrefslogtreecommitdiff
path: root/sys-fs/mount-zip/mount-zip-1.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/mount-zip/mount-zip-1.0.12.ebuild')
-rw-r--r--sys-fs/mount-zip/mount-zip-1.0.12.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-fs/mount-zip/mount-zip-1.0.12.ebuild b/sys-fs/mount-zip/mount-zip-1.0.12.ebuild
new file mode 100644
index 000000000000..9a3a0c705708
--- /dev/null
+++ b/sys-fs/mount-zip/mount-zip-1.0.12.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="FUSE file system for ZIP archives"
+HOMEPAGE="https://github.com/google/mount-zip"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/libzip:=
+ sys-fs/fuse:0=
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+DOCS=( changelog README.md )
+
+src_configure() {
+ tc-export AR CC CXX PKG_CONFIG
+ default
+}
+
+src_install() {
+ default
+ doman mount-zip.1
+}
+
+src_test() {
+ addwrite /dev/fuse
+ default
+}