summaryrefslogtreecommitdiff
path: root/sys-fs/ncdu-bin/ncdu-bin-2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/ncdu-bin/ncdu-bin-2.2.ebuild')
-rw-r--r--sys-fs/ncdu-bin/ncdu-bin-2.2.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/sys-fs/ncdu-bin/ncdu-bin-2.2.ebuild b/sys-fs/ncdu-bin/ncdu-bin-2.2.ebuild
index 290db5ad4cc5..b003a0343eee 100644
--- a/sys-fs/ncdu-bin/ncdu-bin-2.2.ebuild
+++ b/sys-fs/ncdu-bin/ncdu-bin-2.2.ebuild
@@ -3,19 +3,32 @@
EAPI=8
+inherit verify-sig
+
DESCRIPTION="NCurses Disk Usage"
-HOMEPAGE="https://dev.yorhel.nl/ncdu/"
+HOMEPAGE="https://dev.yorhel.nl/ncdu"
SRC_URI="
amd64? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-x86_64.tar.gz )
arm? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-arm.tar.gz )
arm64? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-aarch64.tar.gz )
- x86? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-i386.tar.gz )"
+ x86? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-i386.tar.gz )
+ verify-sig? (
+ amd64? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-x86_64.tar.gz.asc )
+ arm? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-arm.tar.gz.asc )
+ arm64? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-aarch64.tar.gz.asc )
+ x86? ( https://dev.yorhel.nl/download/ncdu-${PV}-linux-i386.tar.gz.asc )
+ )
+"
S="${WORKDIR}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="-* ~amd64 ~arm ~arm64 ~x86"
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-yorhel )"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/yoranheling.asc
+
QA_PREBUILT="usr/bin/ncdu-bin"
src_install() {