summaryrefslogtreecommitdiff
path: root/sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch')
-rw-r--r--sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch b/sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch
new file mode 100644
index 000000000000..d73f02f8ce81
--- /dev/null
+++ b/sys-fs/quotatool/files/quotatool-1.4.13-ldflags.patch
@@ -0,0 +1,23 @@
+--- quotatool-1.4.13/local.mk.in
++++ quotatool-1.4.13/local.mk.in
+@@ -17,7 +17,8 @@
+
+ CC := @CC@
+ CFLAGS := @CFLAGS@
+-CPPFLAGS = $(inc) @DEFS@
++LDFLAGS := @LDFLAGS@
++CPPFLAGS = @CPPFLAGS@ $(inc) @DEFS@
+
+
+ INSTALL := @INSTALL@
+--- quotatool-1.4.13/Makefile
++++ quotatool-1.4.13/Makefile
+@@ -58,7 +58,7 @@
+ # compile the program (and the objects)
+ all: $(prog)
+ $(prog): $(objs)
+- $(CC) -o $(prog) $(objs) $(libs) $(CFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(prog) $(objs) $(libs)
+
+
+