summaryrefslogtreecommitdiff
path: root/sys-fs/squashfs-tools-ng
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squashfs-tools-ng')
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest2
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.3.2.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
index 3cd46952f130..de2d7bc19ce0 100644
--- a/sys-fs/squashfs-tools-ng/Manifest
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -1,4 +1,6 @@
DIST squashfs-tools-ng-1.3.1.tar.xz 585916 BLAKE2B 697131ddb9959bed388534f90c93e2e7495ef5aec9facf97e7d17475cff64d7a4badb709a16ae5e6da3ee89b1a1e3a49833bd15b9a0b4b364e15a565bd18e480 SHA512 0a433f7c3633cd5d8646d990744e31ed59c7012d5f8bb4fdb7892b892631f22a8fd0969f7d81de68f53e44670e71cb8e29729cd925a93b98ab3b6942bbc30662
+DIST squashfs-tools-ng-1.3.2.tar.xz 585380 BLAKE2B 43e8e7c189a9e3a23964a9ae17666eba7ff362d7ed011ee09e342d9ef777de2ce8e326cd38fa0932ace33929cf75bab81786ca56411053c08041300459262076 SHA512 6f14d90875ef3f3d36d3cd38932ade6b0da7284922c914bd655e3f0a4abb17ba75d4bc052a1d4244c1b4ff96b3798d83d5a7b3263b8e1b96c112f4cdf967400f
EBUILD squashfs-tools-ng-1.3.1.ebuild 1202 BLAKE2B 165800a2c038c2db19d92b223632838b760253c0007f307b3a7ed6022719369c0bb0ecf7619e77ccab20f168e7a33a2a2b93f3679d91a58aedac86ee28b4fec7 SHA512 822bc8b4b244574035669e6f3c11d18887ad5defca3842ca8ca29073899000caec607dc443b68d644cf6e350d7c85fcfdd418bec3a9ea34d8405443524c4754e
+EBUILD squashfs-tools-ng-1.3.2.ebuild 1204 BLAKE2B b8b54ade8c7e6992480634256f78e71bb76effa373d02f608ad1725047013d099d38e1460a41b3d77ad8e10844c8066c5fa02890c44b71b59145d6ab600f2828 SHA512 89b3ef25cdce77a9a503f7c7e6194b6b111765c3f3ac0c6453c6803a15f16b27b0aaf6f4c426f4c36ae71dd698ae464377e71b94702bd0c00a29d73522c6875b
EBUILD squashfs-tools-ng-9999.ebuild 1204 BLAKE2B b8b54ade8c7e6992480634256f78e71bb76effa373d02f608ad1725047013d099d38e1460a41b3d77ad8e10844c8066c5fa02890c44b71b59145d6ab600f2828 SHA512 89b3ef25cdce77a9a503f7c7e6194b6b111765c3f3ac0c6453c6803a15f16b27b0aaf6f4c426f4c36ae71dd698ae464377e71b94702bd0c00a29d73522c6875b
MISC metadata.xml 453 BLAKE2B 4bfc83a611fe2b8da5ce57e56c438c671489d0944cbb4b3f82113bac6bee89028091551c1c96953f166959b087d7e776b28ecb6b9290489f007ea5ca33090ebf SHA512 013b8d87af8c6298eaba48b4aa4282a8781321b0a15d1a8745361e389bb6c5ae6957b24af4bb6b88125cff5f9824b0e878051bd395fdeb98c2ae0ef7f2b370a7
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.3.2.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.3.2.ebuild
new file mode 100644
index 000000000000..e768bb9ae947
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.3.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ inherit libtool
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-3+ BSD-2 MIT tools? ( GPL-3+ )"
+SLOT="0"
+IUSE="lz4 +lzma lzo selinux +tools zstd"
+
+DEPEND="
+ app-arch/bzip2:=
+ sys-libs/zlib:=
+ lz4? ( app-arch/lz4:= )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo:2 )
+ selinux? ( sys-libs/libselinux:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ if [[ ${PV} = "9999" ]]; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with tools)
+ $(use_with lzma xz)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}