summaryrefslogtreecommitdiff
path: root/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild')
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
index 2c3037f0258e..480634c6bacb 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-2.1.ebuild
@@ -4,7 +4,7 @@
EAPI="7"
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-any-r1
+inherit python-any-r1 toolchain-funcs
DESCRIPTION="Self-syncing tree-merging file system based on FUSE"
HOMEPAGE="https://github.com/rpodgorny/unionfs-fuse"
@@ -32,6 +32,10 @@ python_check_deps() {
has_version "dev-python/pytest[${PYTHON_USEDEP}]"
}
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
}