summaryrefslogtreecommitdiff
path: root/sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-0.ebuild')
-rw-r--r--sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-0.ebuild b/sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-0.ebuild
new file mode 100644
index 000000000000..725a7967a3e1
--- /dev/null
+++ b/sys-kernel/installkernel-systemd-boot/installkernel-systemd-boot-0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wrap kernel-install from systemd-boot as installkernel"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI=""
+S=${WORKDIR}
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="|| ( sys-apps/systemd sys-boot/systemd-boot )
+ !<sys-apps/debianutils-4.9-r1[installkernel]
+ !sys-kernel/installkernel-gentoo"
+
+src_install() {
+ # we could technically use a symlink here but it would require
+ # us to know the correct path, and that implies /usr merge problems
+ into /
+ newsbin - installkernel <<-EOF
+ #!/bin/sh
+ exec kernel-install add "\${1}" "\${2}"
+ EOF
+}