summaryrefslogtreecommitdiff
path: root/sys-kernel/rt-sources/files/rt-sources-posix-printf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/rt-sources/files/rt-sources-posix-printf.patch')
-rw-r--r--sys-kernel/rt-sources/files/rt-sources-posix-printf.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/rt-sources/files/rt-sources-posix-printf.patch b/sys-kernel/rt-sources/files/rt-sources-posix-printf.patch
new file mode 100644
index 000000000000..81ebcaf0eca9
--- /dev/null
+++ b/sys-kernel/rt-sources/files/rt-sources-posix-printf.patch
@@ -0,0 +1,40 @@
+From 651e54953b5d4ad103f0efa54fc6b380807fca3a Mon Sep 17 00:00:00 2001
+From: Thomas Schneider <qsx@qsx.re>
+Date: Fri, 14 Oct 2016 21:29:49 +0200
+Subject: security/apparmor: Use POSIX-compatible "printf '%s'"
+
+When using a strictly POSIX-compliant shell, "-n #define ..." gets
+written into the file. Use "printf '%s'" to avoid this.
+
+Signed-off-by: Thomas Schneider <qsx@qsx.re>
+Signed-off-by: John Johansen <john.johansen@canonical.com>
+---
+ security/apparmor/Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+(limited to 'security/apparmor')
+
+diff --git a/security/apparmor/Makefile b/security/apparmor/Makefile
+index ad369a7..2ded2f1 100644
+--- a/security/apparmor/Makefile
++++ b/security/apparmor/Makefile
+@@ -20,7 +20,7 @@ cmd_make-caps = echo "static const char *const capability_names[] = {" > $@ ;\
+ sed $< >>$@ -r -n -e '/CAP_FS_MASK/d' \
+ -e 's/^\#define[ \t]+CAP_([A-Z0-9_]+)[ \t]+([0-9]+)/[\2] = "\L\1",/p';\
+ echo "};" >> $@ ;\
+- echo -n '\#define AA_FS_CAPS_MASK "' >> $@ ;\
++ printf '%s' '\#define AA_FS_CAPS_MASK "' >> $@ ;\
+ sed $< -r -n -e '/CAP_FS_MASK/d' \
+ -e 's/^\#define[ \t]+CAP_([A-Z0-9_]+)[ \t]+([0-9]+)/\L\1/p' | \
+ tr '\n' ' ' | sed -e 's/ $$/"\n/' >> $@
+@@ -56,7 +56,7 @@ cmd_make-rlim = echo "static const char *const rlim_names[RLIM_NLIMITS] = {" \
+ echo "static const int rlim_map[RLIM_NLIMITS] = {" >> $@ ;\
+ sed -r -n "s/^\# ?define[ \t]+(RLIMIT_[A-Z0-9_]+).*/\1,/p" $< >> $@ ;\
+ echo "};" >> $@ ; \
+- echo -n '\#define AA_FS_RLIMIT_MASK "' >> $@ ;\
++ printf '%s' '\#define AA_FS_RLIMIT_MASK "' >> $@ ;\
+ sed -r -n 's/^\# ?define[ \t]+RLIMIT_([A-Z0-9_]+).*/\L\1/p' $< | \
+ tr '\n' ' ' | sed -e 's/ $$/"\n/' >> $@
+
+--
+cgit v1.1