summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-2.30-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.30-r3.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.30-r3.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/glibc/glibc-2.30-r3.ebuild b/sys-libs/glibc/glibc-2.30-r3.ebuild
index 7bbdf0c882ad..d1da04b428a1 100644
--- a/sys-libs/glibc/glibc-2.30-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.30-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit python-any-r1 prefix eutils toolchain-funcs flag-o-matic gnuconfig \
multilib systemd multiprocessing
@@ -929,7 +929,7 @@ glibc_do_configure() {
--host=${CTARGET_OPT:-${CTARGET}}
$(use_enable profile)
$(use_with gd)
- --with-headers=$(alt_build_headers)
+ --with-headers=$(build_eprefix)$(alt_build_headers)
--prefix="$(host_eprefix)/usr"
--sysconfdir="$(host_eprefix)/etc"
--localstatedir="$(host_eprefix)/var"
@@ -1084,7 +1084,7 @@ glibc_headers_configure() {
--enable-bind-now
--build=${CBUILD_OPT:-${CBUILD}}
--host=${CTARGET_OPT:-${CTARGET}}
- --with-headers=$(alt_build_headers)
+ --with-headers=$(build_eprefix)$(alt_build_headers)
--prefix="$(host_eprefix)/usr"
${EXTRA_ECONF}
)