summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-2.35-r10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.35-r10.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.35-r10.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.35-r10.ebuild b/sys-libs/glibc/glibc-2.35-r10.ebuild
index c07be651ccb0..bf55284796ae 100644
--- a/sys-libs/glibc/glibc-2.35-r10.ebuild
+++ b/sys-libs/glibc/glibc-2.35-r10.ebuild
@@ -183,6 +183,15 @@ XFAIL_TEST_LIST=(
# Small helper functions
#
+dump_build_environment() {
+ einfo ==== glibc build environment ========================================================
+ local v
+ for v in ABI CBUILD CHOST CTARGET CBUILD_OPT CTARGET_OPT CC CXX CPP LD {AS,C,CPP,CXX,LD}FLAGS MAKEINFO NM AR AS STRIP RANLIB OBJCOPY STRINGS OBJDUMP READELF; do
+ einfo " $(printf '%15s' ${v}:) ${!v}"
+ done
+ einfo =====================================================================================
+}
+
is_crosscompile() {
[[ ${CHOST} != ${CTARGET} ]]
}
@@ -520,7 +529,12 @@ setup_env() {
export __ORIG_CXX=${CXX}
if tc-is-clang && ! use custom-cflags && ! is_crosscompile ; then
+ export glibc__force_gcc=yes
+ # once this is toggled on, it needs to stay on, since with CPP manipulated
+ # tc-is-clang does not work correctly anymore...
+ fi
+ if [[ ${glibc__force_gcc} == "yes" ]] ; then
# If we are running in an otherwise clang/llvm environment, we need to
# recover the proper gcc and binutils settings here, at least until glibc
# is finally building with clang. So let's override everything that is
@@ -537,6 +551,7 @@ setup_env() {
einfo "Overriding clang configuration, since it won't work here"
export CC="${current_gcc_path}/gcc"
+ export CPP="${current_gcc_path}/cpp"
export CXX="${current_gcc_path}/g++"
export LD="${current_binutils_path}/ld.bfd"
export AR="${current_binutils_path}/ar"
@@ -912,13 +927,8 @@ src_prepare() {
}
glibc_do_configure() {
+ dump_build_environment
- local v
- for v in ABI CBUILD CHOST CTARGET CBUILD_OPT CTARGET_OPT CC CXX LD {AS,C,CPP,CXX,LD}FLAGS MAKEINFO NM AR AS STRIP RANLIB OBJCOPY STRINGS OBJDUMP READELF; do
- einfo " $(printf '%15s' ${v}:) ${!v}"
- done
-
- echo
local myconf=()
# Use '=strong' instead of '=all' to protect only functions