summaryrefslogtreecommitdiff
path: root/sys-libs/libcxx/libcxx-7.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libcxx/libcxx-7.0.9999.ebuild')
-rw-r--r--sys-libs/libcxx/libcxx-7.0.9999.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-libs/libcxx/libcxx-7.0.9999.ebuild b/sys-libs/libcxx/libcxx-7.0.9999.ebuild
index e5777074eeda..536457a13802 100644
--- a/sys-libs/libcxx/libcxx-7.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-7.0.9999.ebuild
@@ -90,7 +90,9 @@ test_compiler() {
<<<'int main() { return 0; }' &>/dev/null
}
-multilib_src_configure() {
+src_configure() {
+ # note: we need to do this before multilib kicks in since it will
+ # alter the CHOST
local cxxabi cxxabi_incs
if use libcxxabi; then
cxxabi=libcxxabi
@@ -104,6 +106,10 @@ multilib_src_configure() {
cxxabi_incs="${gcc_inc};${gcc_inc}/${CHOST}"
fi
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
# we want -lgcc_s for unwinder, and for compiler runtime when using
# gcc, clang with gcc runtime (or any unknown compiler)
local extra_libs=() want_gcc_s=ON