summaryrefslogtreecommitdiff
path: root/sys-libs/libnbd/libnbd-1.14.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libnbd/libnbd-1.14.1.ebuild')
-rw-r--r--sys-libs/libnbd/libnbd-1.14.1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sys-libs/libnbd/libnbd-1.14.1.ebuild b/sys-libs/libnbd/libnbd-1.14.1.ebuild
new file mode 100644
index 000000000000..67aff2662660
--- /dev/null
+++ b/sys-libs/libnbd/libnbd-1.14.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="NBD client library in userspace"
+HOMEPAGE="https://gitlab.com/nbdkit/libnbd"
+SRC_URI="https://download.libguestfs.org/libnbd/$(ver_cut 1-2)-stable/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="fuse gnutls uri-support test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse:3 )
+ gnutls? ( net-libs/gnutls:= )
+ uri-support? ( dev-libs/libxml2 )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( sys-block/nbd[gnutls?] )
+"
+BDEPEND="dev-lang/perl"
+
+src_prepare() {
+ default
+
+ # Some tests require impossible to provide features, such as fuse.
+ # These are marked by requires_... in the functions.sh shell
+ # library. Rather than listing these tests, let's list out the
+ # impossible to support features and make them skip.
+ cat <<-EOF >> tests/functions.sh.in || die
+ requires_fuse ()
+ {
+ requires false
+ }
+ EOF
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable fuse)
+ $(use_with gnutls)
+ $(use_with uri-support libxml2)
+ --disable-ocaml
+ --disable-python
+ --disable-golang
+ )
+
+ export bashcompdir="$(get_bashcompdir)"
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}