summaryrefslogtreecommitdiff
path: root/sys-libs/libsepol
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libsepol')
-rw-r--r--sys-libs/libsepol/Manifest2
-rw-r--r--sys-libs/libsepol/libsepol-3.8.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-libs/libsepol/Manifest b/sys-libs/libsepol/Manifest
index 04cb0acc257e..2d43124d37f7 100644
--- a/sys-libs/libsepol/Manifest
+++ b/sys-libs/libsepol/Manifest
@@ -1,6 +1,8 @@
DIST libsepol-3.6.tar.gz 509100 BLAKE2B c073c9437004df0c723125971ed26354dc6b8a78b069c593977062527342061303bcc48917fcd9623d17998748254f63408b233173f3c62e92ee0ea2f3c4a430 SHA512 35a42d2749fc4f71bc6b7488380714f56975564007128566f1c73e5c50bf81c17535b2cfda4583aacb4870aa2cd5885321c01523e415bda8b3326bfefb13d58e
DIST libsepol-3.7.tar.gz 511487 BLAKE2B 8e4a0b2b3731f49d8bc8ea03bd5269672428119578046bc7f38230e3c77459e6b9d4ab39285ea33c89d8e807499ef89faa606e4b4e1ecfac2c3d445454b16420 SHA512 85d12d0ba5a7a3225f08d041a18fd59641608db5e0a78a1e9649754e45be54a807cd422d4889b88da6e806b4af546336c7a0913448f08ac33dc6ffb983890ef8
+DIST libsepol-3.8.tar.gz 513780 BLAKE2B aca232da4f6bc21638f3e76d96c8349109edb64d8134c7d9c64bd4ee25c7ebbf69829eaa92493e0522a2a13e97a70f82514f24c6fff62e17f2a6874dd3fed516 SHA512 06da9bac1075b54177c3237994f3db0f9a50e16a363874df7ba11a52084bce4af9623ecfc1db1779b555dee6aab62fbfbf1cd03cf5760bd00f74ea5775897e09
EBUILD libsepol-3.6.ebuild 1114 BLAKE2B 94ab8f288daf3208748785f0440c24bbd4af0477f383c5d570db7a7d8eb98fe1f910d419a5fd41cb063bb06e7898a34b66dff7655e08f894e357324b99516a2d SHA512 be5926d4a51c07270d7cadacbaf8208b68803133c4a372127ad6f5e45261b0ca7a6cc5521a1f006805aacab721a0329a72fa40e4c87865723f054e23d55afb2c
EBUILD libsepol-3.7.ebuild 1197 BLAKE2B add6fc44ab8a13b5f953233445ed57aca7e9fe4072f11270103767e6e9c42e8821cee31d6bb5b31c7132f3f2e8b39e96fa386244d95e2d4604448d899b6cac04 SHA512 c427f7c086224fe171e7bdb45622ad99f2a2aa5dca65fc970ff51ee77f4e876df94fc682903e5c0aba64e2d1e5916f18629f0f4f53399dc8067ac14bbf3c6d84
+EBUILD libsepol-3.8.ebuild 1201 BLAKE2B 5223e65d0a38d4c4a885733d29434fd8e16174d50a1967f9d115fc3571baf6a633edc5bcd3e6f7a3d24bee3f637511ea9523f4639d0dd53d223dcf1eb440b060 SHA512 672c45e136fa5daaa17fa81fd9d27ecf4a6a8d4091488586a8ccd6e97a4ca8849460233383e935ffe946f7a461e64c1a882821f6d537b4ed5f2acf02f9143645
EBUILD libsepol-9999.ebuild 1201 BLAKE2B 2788cdd6371440168ffcbb90b93df66b7ce88f9476d37634e7d4e34706b408d20eef13bb2d9e97052a55f103549a32dc7de1084d37c68d27616ac39e4f3fbd6d SHA512 4df5ac41cbab2fb2db540badc40e1a7055a074ab8382213aec78579341729b297dd340e0b7355c9e168a0d56cf1e5a36f215789b5308cfcc194bf687caff6816
MISC metadata.xml 402 BLAKE2B 0450441687952fc82e64536652076085d66870e8cd81d9aaa99d023d17d46bc8ef6627c9ebdd6084b4c60e7d26edb61b4aaf5693794105b04b500c74a37c25be SHA512 a107ad99e8050f4cbe1c32f76699524afdced1f4b9a0c0fb3a4b5954d4f9cd5993d4d047d7a3fb45fb68c2be361c658be48287e1099ea7a6b6fca7d676969c2d
diff --git a/sys-libs/libsepol/libsepol-3.8.ebuild b/sys-libs/libsepol/libsepol-3.8.ebuild
new file mode 100644
index 000000000000..041e040a37da
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-3.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit toolchain-funcs multilib-minimal
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/2"
+IUSE="+static-libs"
+
+# tests are not meant to be run outside of the full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+ multilib_copy_sources
+}
+
+my_make() {
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="${EPREFIX}/$(get_libdir)" \
+ "${@}"
+}
+
+multilib_src_compile() {
+ tc-export CC AR RANLIB
+
+ local -x CFLAGS="${CFLAGS} -fno-semantic-interposition"
+
+ my_make
+}
+
+multilib_src_install() {
+ my_make DESTDIR="${D}" install
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a || die
+}