summaryrefslogtreecommitdiff
path: root/sys-libs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/Manifest.gzbin14751 -> 14743 bytes
-rw-r--r--sys-libs/libselinux/Manifest4
-rw-r--r--sys-libs/libselinux/libselinux-3.6.ebuild158
-rw-r--r--sys-libs/libselinux/libselinux-9999.ebuild8
-rw-r--r--sys-libs/libsemanage/Manifest4
-rw-r--r--sys-libs/libsemanage/libsemanage-3.6.ebuild130
-rw-r--r--sys-libs/libsemanage/libsemanage-9999.ebuild2
-rw-r--r--sys-libs/libsepol/Manifest4
-rw-r--r--sys-libs/libsepol/libsepol-3.6.ebuild50
-rw-r--r--sys-libs/libsepol/libsepol-9999.ebuild2
10 files changed, 353 insertions, 9 deletions
diff --git a/sys-libs/Manifest.gz b/sys-libs/Manifest.gz
index 72d9df9b51c5..198ef37edd43 100644
--- a/sys-libs/Manifest.gz
+++ b/sys-libs/Manifest.gz
Binary files differ
diff --git a/sys-libs/libselinux/Manifest b/sys-libs/libselinux/Manifest
index fb0399138752..2812c2ee200f 100644
--- a/sys-libs/libselinux/Manifest
+++ b/sys-libs/libselinux/Manifest
@@ -1,4 +1,6 @@
DIST libselinux-3.5.tar.gz 211453 BLAKE2B f7f3067c4bb0448e18bd7085135f11d94ae99728949480a655c0f660486817beb5829d8a43dff7bce286ccd50705b0c657bde85970f01c794e01fb707f469d8b SHA512 4e13261a5821018a5f3cdce676f180bb62e5bc225981ca8a498ece0d1c88d9ba8eaa0ce4099dd0849309a8a7c5a9a0953df841a9922f2c284e5a109e5d937ba7
+DIST libselinux-3.6.tar.gz 194210 BLAKE2B 615198d47ecfb4b6274810cbe32cce5953dd44d1d04e8ce244213dc4ddbd61cde3515f4650046b805cf98f341aba718af8d7a9e1d66773172031ac19599f6032 SHA512 182dcdf3510083ff4b9376a4a6d6a7b33905ac3c5e974c188bf3965686c54b663162c543ecf15eab75102f3c91a2502d33d0f1104dec01dd9b14737ef3f2b544
EBUILD libselinux-3.5-r1.ebuild 4112 BLAKE2B 8787a7c9c9c5a6f52fbab464530539119ff1a1e8acfd61fee8738794bc79aebaf89e03b6f0ab82cd92bc8e3b56bd6346a3ca0f502b0fb6c0f9c55d0a8ba2635a SHA512 eed2053ed74bdfeea643b4495410c0174884a7ae9a94c1dea37a63367649b8a1c1aed9cf2d85f624e216ba709340ef336e7627be664fe85d5e666a95e253f429
-EBUILD libselinux-9999.ebuild 4081 BLAKE2B 653263477834909cbdf597ad7fe6f672a4d35bed5c50dd34e1eabc412b176eb0c5c37f630701f1a9072605b537a66dca6eec7f5fa685d220dfd16815fd5882db SHA512 1f66c199a91bf0f051103488efcb87c77c0790d86e8644d1ab93d0048afe5b2ed08701efdfe33109c01766744aa8df7ade990ecafdd305050ca4e0302fd39404
+EBUILD libselinux-3.6.ebuild 4081 BLAKE2B c3b3c5c5963632a63c2303e5072e69cc6c36029f938bed0766bee89799192a1b16735f163ffebea29705f5d422ffc655e17501d514f228e936bdb087cfbcdfc8 SHA512 34fcb915d280ad495cf25aca9f6b3810ae5403d3faa10f04dc7a6d928f44981fbe954709061e99bb3532520b9d9085ca377c2ac6fa718fcb59dc6f010fd13c14
+EBUILD libselinux-9999.ebuild 4081 BLAKE2B c3b3c5c5963632a63c2303e5072e69cc6c36029f938bed0766bee89799192a1b16735f163ffebea29705f5d422ffc655e17501d514f228e936bdb087cfbcdfc8 SHA512 34fcb915d280ad495cf25aca9f6b3810ae5403d3faa10f04dc7a6d928f44981fbe954709061e99bb3532520b9d9085ca377c2ac6fa718fcb59dc6f010fd13c14
MISC metadata.xml 649 BLAKE2B 0d4704823be4492064b2d69a31581397cdedc9e5d564090d9770aa79124c53a66f98290fb4de22abb4f81e732267589ad1df3beda2bb71a3cf5a70f84b885dc4 SHA512 6b240fad142e4ba6457f70c83fb3171c6869ed4ac5729d51b8cc159b2471959c24a0a290ff91fa1d90e0f24f96be76a69487174de22c603539f3fc0e7109a561
diff --git a/sys-libs/libselinux/libselinux-3.6.ebuild b/sys-libs/libselinux/libselinux-3.6.ebuild
new file mode 100644
index 000000000000..941b189dd857
--- /dev/null
+++ b/sys-libs/libselinux/libselinux-3.6.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{10..12} )
+USE_RUBY="ruby31 ruby32 ruby33"
+
+# No, I am not calling ruby-ng
+inherit python-r1 toolchain-funcs multilib-minimal
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux userland library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="public-domain"
+SLOT="0"
+IUSE="python ruby static-libs ruby_targets_ruby31 ruby_targets_ruby32 ruby_targets_ruby33"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="dev-libs/libpcre2:=[static-libs?,${MULTILIB_USEDEP}]
+ >=sys-libs/libsepol-${PV}:=[${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )
+ ruby? (
+ ruby_targets_ruby31? ( dev-lang/ruby:3.1 )
+ ruby_targets_ruby32? ( dev-lang/ruby:3.2 )
+ ruby_targets_ruby33? ( dev-lang/ruby:3.3 )
+ )
+ elibc_musl? ( sys-libs/fts-standalone )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ python? (
+ >=dev-lang/swig-2.0.9
+ dev-python/pip[${PYTHON_USEDEP}]
+)
+ ruby? ( >=dev-lang/swig-2.0.9 )"
+
+src_prepare() {
+ eapply_user
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export AR CC PKG_CONFIG RANLIB
+
+ local -x CFLAGS="${CFLAGS} -fno-semantic-interposition"
+
+ emake \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ LDFLAGS="-fPIC ${LDFLAGS} -pthread" \
+ USE_PCRE2=y \
+ FTS_LDLIBS="$(usex elibc_musl '-lfts' '')" \
+ all
+
+ if multilib_is_native_abi && use python; then
+ building() {
+ emake \
+ LDFLAGS="-fPIC ${LDFLAGS} -lpthread" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ USE_PCRE2=y \
+ FTS_LDLIBS="$(usex elibc_musl '-lfts' '')" \
+ pywrap
+ }
+ python_foreach_impl building
+ fi
+
+ if multilib_is_native_abi && use ruby; then
+ building() {
+ einfo "Calling rubywrap for ${1}"
+ # Clean up .lo file to force rebuild
+ rm -f src/selinuxswig_ruby_wrap.lo || die
+ emake \
+ RUBY=${1} \
+ LDFLAGS="-fPIC ${LDFLAGS} -lpthread" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ USE_PCRE2=y \
+ FTS_LDLIBS="$(usex elibc_musl '-lfts' '')" \
+ rubywrap
+ }
+ for RUBYTARGET in ${USE_RUBY}; do
+ use ruby_targets_${RUBYTARGET} || continue
+
+ building ${RUBYTARGET}
+ done
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ USE_PCRE2=y \
+ install
+
+ if multilib_is_native_abi && use python; then
+ installation() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ USE_PCRE2=y \
+ install-pywrap
+ python_optimize # bug 531638
+ }
+ python_foreach_impl installation
+ fi
+
+ if multilib_is_native_abi && use ruby; then
+ installation() {
+ einfo "Calling install-rubywrap for ${1}"
+ # Forcing (re)build here as otherwise the resulting SO file is used for all ruby versions
+ rm src/selinuxswig_ruby_wrap.lo
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ RUBY=${1} \
+ USE_PCRE2=y \
+ install-rubywrap
+ }
+ for RUBYTARGET in ${USE_RUBY}; do
+ use ruby_targets_${RUBYTARGET} || continue
+
+ installation ${RUBYTARGET}
+ done
+ fi
+
+ use static-libs || rm "${D}"/usr/lib*/*.a || die
+}
+
+pkg_postinst() {
+ # Fix bug 473502
+ for POLTYPE in ${POLICY_TYPES};
+ do
+ mkdir -p /etc/selinux/${POLTYPE}/contexts/files || die
+ touch /etc/selinux/${POLTYPE}/contexts/files/file_contexts.local || die
+ # Fix bug 516608
+ for EXPRFILE in file_contexts file_contexts.homedirs file_contexts.local ; do
+ if [[ -f "/etc/selinux/${POLTYPE}/contexts/files/${EXPRFILE}" ]]; then
+ sefcontext_compile /etc/selinux/${POLTYPE}/contexts/files/${EXPRFILE} \
+ || die "Failed to recompile contexts"
+ fi
+ done
+ done
+}
diff --git a/sys-libs/libselinux/libselinux-9999.ebuild b/sys-libs/libselinux/libselinux-9999.ebuild
index f5475a7744c4..941b189dd857 100644
--- a/sys-libs/libselinux/libselinux-9999.ebuild
+++ b/sys-libs/libselinux/libselinux-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
PYTHON_COMPAT=( python3_{10..12} )
-USE_RUBY="ruby30 ruby31 ruby32"
+USE_RUBY="ruby31 ruby32 ruby33"
# No, I am not calling ruby-ng
inherit python-r1 toolchain-funcs multilib-minimal
@@ -26,16 +26,16 @@ fi
LICENSE="public-domain"
SLOT="0"
-IUSE="python ruby static-libs ruby_targets_ruby30 ruby_targets_ruby31 ruby_targets_ruby32"
+IUSE="python ruby static-libs ruby_targets_ruby31 ruby_targets_ruby32 ruby_targets_ruby33"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="dev-libs/libpcre2:=[static-libs?,${MULTILIB_USEDEP}]
>=sys-libs/libsepol-${PV}:=[${MULTILIB_USEDEP}]
python? ( ${PYTHON_DEPS} )
ruby? (
- ruby_targets_ruby30? ( dev-lang/ruby:3.0 )
ruby_targets_ruby31? ( dev-lang/ruby:3.1 )
ruby_targets_ruby32? ( dev-lang/ruby:3.2 )
+ ruby_targets_ruby33? ( dev-lang/ruby:3.3 )
)
elibc_musl? ( sys-libs/fts-standalone )"
DEPEND="${RDEPEND}"
diff --git a/sys-libs/libsemanage/Manifest b/sys-libs/libsemanage/Manifest
index 0912a664eefb..d24049c14ec7 100644
--- a/sys-libs/libsemanage/Manifest
+++ b/sys-libs/libsemanage/Manifest
@@ -1,6 +1,8 @@
DIST libsemanage-3.4.tar.gz 185177 BLAKE2B 45276ae6f54cf3dc453bc0d99fb4d7439970bb14ff5b909ebc5511ec31bce1d2bdc477ba9c1fb4fd04ab494ccb37cd8bf47a90d81460c2974af2196d9019bf67 SHA512 831dc789545bb9a0b009bdb4f7fe52f6197ad8325946640f886a960d08e40b8a69eccd5a70cce51466bb5cb7f742feb78d19a9ec63383fbd03aa451508677e73
DIST libsemanage-3.5.tar.gz 185060 BLAKE2B 3e08b15cb6b335a2747bd5f0bd84f74abdd22a7e8ec91ebb443ca6fe3886d5e8cd2827fefdaa0e9caf2af3280cffbf593ee828fee54dd423a21b257493cc754c SHA512 959fbd0d6bc6849da6caa13dc41c3f8818cbbd29f04b5d2ac7246c4b395b4f370f113a04cc9cfcb52be2afebfa636013ac4ad4011384c58c7ce066a45cae2751
+DIST libsemanage-3.6.tar.gz 182583 BLAKE2B 3ed9ef06601093983fa41ad6ab9f7eeae241dce98937db04efca6f421afcfd3f59cf5e51d24c596ae03997a398949ed84fbdf629518e3c382a5453129b0a87ab SHA512 8998b6a1b254a9673b99ae4d70a1edc769bb728a44f573cdf62e0a9c9392b77644ee2d70e1936a2f8a9a7f8b063ce98a981f4b8b7060f5b82791889330d69364
EBUILD libsemanage-3.4-r1.ebuild 4405 BLAKE2B 337f44e1d668ed4189b1067285d10c50ead3f917de1fbc768a2cc4c2720faa3de6e7e8af1e4ee9318ccc37aba065fb37433b34d26ff708130c3f57fac2532cdc SHA512 9ab61ab57e6b6e158a6a26cadac1766d4b80c76542933ee0d0daa77c77979232feb88ff602c99e521979b5aff65430d707c0265b269c95d3c4f8fb52a6c215ab
EBUILD libsemanage-3.5.ebuild 4405 BLAKE2B 337f44e1d668ed4189b1067285d10c50ead3f917de1fbc768a2cc4c2720faa3de6e7e8af1e4ee9318ccc37aba065fb37433b34d26ff708130c3f57fac2532cdc SHA512 9ab61ab57e6b6e158a6a26cadac1766d4b80c76542933ee0d0daa77c77979232feb88ff602c99e521979b5aff65430d707c0265b269c95d3c4f8fb52a6c215ab
-EBUILD libsemanage-9999.ebuild 4409 BLAKE2B 4b6879108a250db306c5b64e8a0f590af90e732b6fe55c0b7deec12b63f1d1683cd66c191eddd633777d1fec485405177c67c2e3b721eb2ac3b13a03353dc603 SHA512 2885b3b2e5ee8ea57bb85bae50a2228e90fe54d2dc0b6d2394a6759b0c0b926a302443dd398cb5dd3c16ed8566e6a24f0b0183ccf1738b6b7515c2737d960c4a
+EBUILD libsemanage-3.6.ebuild 4410 BLAKE2B d6926284fa62a98fe9cea873d95059ece06a954401c3d4769d315434f49565ea691029bbd8aa7d3e1918a2ed5a447091444ede1df292a8a5f03d05a0a5593199 SHA512 cefbf0b85ada632525eae3cc0b57f3baf0ddf0990302853274e1db18a124a05b1e600b34960aff50f2db263b7df4b8f66b80ab04b202bbbd1fcbaaf5edbed186
+EBUILD libsemanage-9999.ebuild 4410 BLAKE2B d6926284fa62a98fe9cea873d95059ece06a954401c3d4769d315434f49565ea691029bbd8aa7d3e1918a2ed5a447091444ede1df292a8a5f03d05a0a5593199 SHA512 cefbf0b85ada632525eae3cc0b57f3baf0ddf0990302853274e1db18a124a05b1e600b34960aff50f2db263b7df4b8f66b80ab04b202bbbd1fcbaaf5edbed186
MISC metadata.xml 405 BLAKE2B b41c6e744a90be985e11b1329493febf85889218623fabfc731306b2851f6067bc75126084e40ab82f3b367ef0e13e659dbc930d7786adff967b546fc5f89792 SHA512 8f08f6c3d07f4e76cd4b6a5033dcd7138b3f94c2cab46e1cf89dc9b113810edbe8e6d20298eadefc00b4e32a69057c1ed0c4255144edb2c5e9ce9e139c7dba70
diff --git a/sys-libs/libsemanage/libsemanage-3.6.ebuild b/sys-libs/libsemanage/libsemanage-3.6.ebuild
new file mode 100644
index 000000000000..eb127413897f
--- /dev/null
+++ b/sys-libs/libsemanage/libsemanage-3.6.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit python-r1 toolchain-funcs multilib-minimal
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux kernel and policy management library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/2"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="app-arch/bzip2[${MULTILIB_USEDEP}]
+ >=sys-libs/libsepol-${PV}:=[${MULTILIB_USEDEP}]
+ >=sys-libs/libselinux-${PV}:=[${MULTILIB_USEDEP}]
+ >=sys-process/audit-2.2.2[${MULTILIB_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-lang/swig-2.0.4-r1
+ app-alternatives/yacc
+ app-alternatives/lex
+ virtual/pkgconfig"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+
+ echo >> "${S}/src/semanage.conf"
+ echo "# Set this to true to save the linked policy." >> "${S}/src/semanage.conf"
+ echo "# This is normally only useful for analysis" >> "${S}/src/semanage.conf"
+ echo "# or debugging of policy." >> "${S}/src/semanage.conf"
+ echo "save-linked=false" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Set this to 0 to disable assertion checking." >> "${S}/src/semanage.conf"
+ echo "# This should speed up building the kernel policy" >> "${S}/src/semanage.conf"
+ echo "# from policy modules, but may leave you open to" >> "${S}/src/semanage.conf"
+ echo "# dangerous rules which assertion checking" >> "${S}/src/semanage.conf"
+ echo "# would catch." >> "${S}/src/semanage.conf"
+ echo "expand-check=1" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Modules in the module store can be compressed" >> "${S}/src/semanage.conf"
+ echo "# with bzip2. Set this to the bzip2 blocksize" >> "${S}/src/semanage.conf"
+ echo "# 1-9 when compressing. The higher the number," >> "${S}/src/semanage.conf"
+ echo "# the more memory is traded off for disk space." >> "${S}/src/semanage.conf"
+ echo "# Set to 0 to disable bzip2 compression." >> "${S}/src/semanage.conf"
+ echo "bzip-blocksize=0" >> "${S}/src/semanage.conf"
+ echo >> "${S}/src/semanage.conf"
+ echo "# Reduce memory usage for bzip2 compression and" >> "${S}/src/semanage.conf"
+ echo "# decompression of modules in the module store." >> "${S}/src/semanage.conf"
+ echo "bzip-small=true" >> "${S}/src/semanage.conf"
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ local -x CFLAGS="${CFLAGS} -fno-semantic-interposition"
+
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ all
+
+ if multilib_is_native_abi; then
+ building_py() {
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ "$@"
+ }
+ python_foreach_impl building_py swigify
+ python_foreach_impl building_py pywrap
+ fi
+}
+
+multilib_src_install() {
+ emake \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${ED}" install
+
+ if multilib_is_native_abi; then
+ installation_py() {
+ emake DESTDIR="${ED}" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ install-pywrap
+ python_optimize # bug 531638
+ }
+ python_foreach_impl installation_py
+ fi
+}
+
+multiib_src_install_all() {
+ python_setup
+ python_fix_shebang "${ED}"/usr/libexec/selinux/semanage_migrate_store
+}
+
+pkg_postinst() {
+ # Migrate the SELinux semanage configuration store if not done already
+ local selinuxtype=$(awk -F'=' '/SELINUXTYPE=/ {print $2}' "${EROOT}"/etc/selinux/config 2>/dev/null)
+ if [ -n "${selinuxtype}" ] && [ ! -d "${EROOT}"/var/lib/selinux/${selinuxtype}/active ] ; then
+ ewarn "Since the 2.4 SELinux userspace, the policy module store is moved"
+ ewarn "from /etc/selinux to /var/lib/selinux. The migration will be run now."
+ ewarn "If there are any issues, it can be done manually by running:"
+ ewarn "/usr/libexec/selinux/semanage_migrate_store"
+ ewarn "For more information, please see"
+ ewarn "- https://github.com/SELinuxProject/selinux/wiki/Policy-Store-Migration"
+ fi
+}
diff --git a/sys-libs/libsemanage/libsemanage-9999.ebuild b/sys-libs/libsemanage/libsemanage-9999.ebuild
index 7c2c0548cf0e..eb127413897f 100644
--- a/sys-libs/libsemanage/libsemanage-9999.ebuild
+++ b/sys-libs/libsemanage/libsemanage-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit python-r1 toolchain-funcs multilib-minimal
diff --git a/sys-libs/libsepol/Manifest b/sys-libs/libsepol/Manifest
index 6adf8858b6ba..a0a556594451 100644
--- a/sys-libs/libsepol/Manifest
+++ b/sys-libs/libsepol/Manifest
@@ -1,4 +1,6 @@
DIST libsepol-3.5.tar.gz 497522 BLAKE2B dad2d346605be53fe41aef69e2e4bd4f1ce68a15f0b9307deb6b66bbe7bf06a9ee6be580e60d2f19aebbc8ee5041ac8a7b831b51342ba7c7089e1f1a447e7691 SHA512 66f45a9f4951589855961955db686b006b4c0cddead6ac49ad238a0e4a34775905bd10fb8cf0c0ff2ab64f9b7d8366b97fcd5b19c382dec39971a2835cc765c8
+DIST libsepol-3.6.tar.gz 509100 BLAKE2B c073c9437004df0c723125971ed26354dc6b8a78b069c593977062527342061303bcc48917fcd9623d17998748254f63408b233173f3c62e92ee0ea2f3c4a430 SHA512 35a42d2749fc4f71bc6b7488380714f56975564007128566f1c73e5c50bf81c17535b2cfda4583aacb4870aa2cd5885321c01523e415bda8b3326bfefb13d58e
EBUILD libsepol-3.5.ebuild 1114 BLAKE2B e2dd440d5fcdd3e3dce67bb25a5180cdda5dd534c4f5fa42b30acf1f33fa5d794583fb7808b4b39b3a7003850bb08b12bf8fbdaede1b7c3c6986c365e8d7090b SHA512 1cbd7242dfa76531be30bb7d897ca8fa05be2357351b6b276fbf14958785c5620edf1cce8d3af16a0b8d8fbcb9e1d883ffa6a9313ace5bf73278644234a10043
-EBUILD libsepol-9999.ebuild 1118 BLAKE2B 7b0047c08b1a5d27e6ec4db8722880d12cf7d2946a1e6fade6b505662f2347b18c9faa686b58bce24e22892eae1bec3c9428c7131a593c711845a56868322215 SHA512 86083220febcf661958a30a025bf4e39eefa2bdac60d3217b3702212fa573e08ba92cce2c0b64a586a8b63510f1882550bc78203ebc7346bab7a35f8b7b39294
+EBUILD libsepol-3.6.ebuild 1118 BLAKE2B 88169dc0f0dedfb3c83e8e494fc94867adb857186045d2864f6fcf47b05815c3a73933e68c2a21b51673ceeb823b291c934340bd8cbc6d1f273419c49c96e90c SHA512 af8780c69339ed629c8da06b60ad0798de4af367b3afaadc534fb28db016635c306ffd75e713cf921366cdda4eda84c161e1b22beecab4dec2d91af7b8475937
+EBUILD libsepol-9999.ebuild 1118 BLAKE2B 88169dc0f0dedfb3c83e8e494fc94867adb857186045d2864f6fcf47b05815c3a73933e68c2a21b51673ceeb823b291c934340bd8cbc6d1f273419c49c96e90c SHA512 af8780c69339ed629c8da06b60ad0798de4af367b3afaadc534fb28db016635c306ffd75e713cf921366cdda4eda84c161e1b22beecab4dec2d91af7b8475937
MISC metadata.xml 402 BLAKE2B 0450441687952fc82e64536652076085d66870e8cd81d9aaa99d023d17d46bc8ef6627c9ebdd6084b4c60e7d26edb61b4aaf5693794105b04b500c74a37c25be SHA512 a107ad99e8050f4cbe1c32f76699524afdced1f4b9a0c0fb3a4b5954d4f9cd5993d4d047d7a3fb45fb68c2be361c658be48287e1099ea7a6b6fca7d676969c2d
diff --git a/sys-libs/libsepol/libsepol-3.6.ebuild b/sys-libs/libsepol/libsepol-3.6.ebuild
new file mode 100644
index 000000000000..17fe4da89451
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-3.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs multilib-minimal
+
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/2"
+
+# tests are not meant to be run outside of the full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export CC AR RANLIB
+
+ local -x CFLAGS="${CFLAGS} -fno-semantic-interposition"
+
+ emake \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ SHLIBDIR="/$(get_libdir)" \
+ install
+}
diff --git a/sys-libs/libsepol/libsepol-9999.ebuild b/sys-libs/libsepol/libsepol-9999.ebuild
index f682823e4643..17fe4da89451 100644
--- a/sys-libs/libsepol/libsepol-9999.ebuild
+++ b/sys-libs/libsepol/libsepol-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"