summaryrefslogtreecommitdiff
path: root/sys-libs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/Manifest.gzbin14257 -> 14258 bytes
-rw-r--r--sys-libs/libunwind/Manifest2
-rw-r--r--sys-libs/libunwind/libunwind-1.6.2-r1.ebuild117
-rw-r--r--sys-libs/llvm-libunwind/Manifest6
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.ebuild2
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-14.0.6.ebuild2
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild2
7 files changed, 125 insertions, 6 deletions
diff --git a/sys-libs/Manifest.gz b/sys-libs/Manifest.gz
index 5b14e9861be4..f457121ac2cd 100644
--- a/sys-libs/Manifest.gz
+++ b/sys-libs/Manifest.gz
Binary files differ
diff --git a/sys-libs/libunwind/Manifest b/sys-libs/libunwind/Manifest
index d1d9f9f29efd..e08b37ac8822 100644
--- a/sys-libs/libunwind/Manifest
+++ b/sys-libs/libunwind/Manifest
@@ -1,3 +1,5 @@
+DIST libunwind-1.6.2-docs.tar.xz 25372 BLAKE2B d16562b29c49070f0cd6ad9211c7c3283b527bd88677d9ce50b15f27254bac504ea79b807e01f4f2bdb05649ff8980f94346ef9737bf5b5bd7c313e547222f10 SHA512 71bcb781cc37ccbef7b349225b1b3b4cd6ba4ce5a48d8478cea17f8245614b672d8e14b5a088e2d998ea717670a371925d4fbe407dde636611f7c2f2901065d8
DIST libunwind-1.6.2.tar.gz 901392 BLAKE2B 3d0313f7e92cbc3e1a84ad3831a5170f21cdf772f1697ca0a59dea63cdd47da382e9f1fd77325d9ff8bcd47559a425dc883a820c646c628cd00faed82cb0f83f SHA512 1d17dfb14f99a894a6cda256caf9ec481c14068aaf8f3a85fa3befa7c7cca7fca0f544a91a3a7c2f2fc55bab19b06a67ca79f55ac9081151d94478c7f611f8f7
+EBUILD libunwind-1.6.2-r1.ebuild 3678 BLAKE2B 03a9e1885931f49a702d561e5ff0ad58ab6acc5dba7bbf01560cddca2cd31cb499042eb36bdb6b3aa0ac88a21abff60b37c762976870a8dd3f806604cffcfedd SHA512 62f6689aa706eee6b6a7ff908bcbf54d0f56472d794b40a60534ca0681ea6495160d9b0e2a4990e837d04c107d9337e41238204d8c1f341eb22f879eebce067e
EBUILD libunwind-1.6.2.ebuild 2680 BLAKE2B 686f5fa9f0362c6669e9195e84f5f35546da5a6d8f66bdf0e9b91a580e1e20b9da4025718ed2f960dff7cbd66d325cb5aec6868b1147bed013486d9ebf4d6b16 SHA512 c44f75111e3a5f97aa85e6124c007c6216445d9ee3cff8418153229a2d97b83b5d97895576993a9c91a457e67f47d74ea50ac755fbbd55f7492a1cbf690ac263
MISC metadata.xml 574 BLAKE2B cf49536a68a838e39d6c67191eff496d8910f1d58cd7830546e519af38972db7cf7add177a6e5902202d2a66bc6b3dadcd261505b3bb61f285f0be10a0db42e7 SHA512 bf5fd787ae0b233c7fe5e8f4b987c472a03b93c07adebf35ce27c7b6759b9ac239296d5ede6725ac11f5030365199533389e51ced10dc6a20bb5aa74baf34ab0
diff --git a/sys-libs/libunwind/libunwind-1.6.2-r1.ebuild b/sys-libs/libunwind/libunwind-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..144c3e79cac5
--- /dev/null
+++ b/sys-libs/libunwind/libunwind-1.6.2-r1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 2005-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Generate using https://github.com/thesamesam/sam-gentoo-scripts/blob/main/niche/generate-libunwind-docs
+# Set to 1 if prebuilt, 0 if not
+# (the construct below is to allow overriding from env for script)
+LIBUNWIND_DOCS_PREBUILT=${LIBUNWIND_DOCS_PREBUILT:-1}
+LIBUNWIND_DOCS_PREBUILT_DEV=sam
+LIBUNWIND_DOCS_VERSION=$(ver_cut 1-3)
+# Default to generating docs (inc. man pages) if no prebuilt; overridden later
+LIBUNWIND_DOCS_USEFLAG="+doc"
+
+[[ ${LIBUNWIND_DOCS_PREBUILT} == 1 ]] && LIBUNWIND_DOCS_USEFLAG="doc"
+
+MY_PV=${PV/_/-}
+MY_P=${PN}-${MY_PV}
+inherit multilib-minimal
+
+DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
+HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
+SRC_URI="mirror://nongnu/libunwind/${MY_P}.tar.gz"
+if [[ ${LIBUNWIND_DOCS_PREBUILT} == 1 ]] ; then
+ SRC_URI+=" !doc? ( https://dev.gentoo.org/~${LIBUNWIND_DOCS_PREBUILT_DEV}/distfiles/${CATEGORY}/${PN}/${PN}-${LIBUNWIND_DOCS_VERSION}-docs.tar.xz )"
+fi
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0/8" # libunwind.so.8
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 -sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug debug-frame ${LIBUNWIND_DOCS_USEFLAG} libatomic lzma static-libs test zlib"
+
+RESTRICT="test !test? ( test )" # some tests are broken (toolchain version dependent, rely on external binaries)
+
+BDEPEND="
+ doc? ( app-text/texlive-core )
+"
+RDEPEND="
+ lzma? ( app-arch/xz-utils[static-libs?,${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib[static-libs?,${MULTILIB_USEDEP}] )
+"
+# We just use the header from libatomic.
+DEPEND="${RDEPEND}
+ libatomic? ( dev-libs/libatomic_ops[${MULTILIB_USEDEP}] )"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/libunwind.h
+
+ # see libunwind.h for the full list of arch-specific headers
+ /usr/include/libunwind-aarch64.h
+ /usr/include/libunwind-arm.h
+ /usr/include/libunwind-hppa.h
+ /usr/include/libunwind-ia64.h
+ /usr/include/libunwind-mips.h
+ /usr/include/libunwind-ppc32.h
+ /usr/include/libunwind-ppc64.h
+ /usr/include/libunwind-riscv.h
+ /usr/include/libunwind-sh.h
+ /usr/include/libunwind-tilegx.h
+ /usr/include/libunwind-x86.h
+ /usr/include/libunwind-x86_64.h
+)
+
+src_prepare() {
+ default
+
+ chmod +x src/ia64/mk_cursor_i || die
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ # --enable-cxx-exceptions: always enable it, headers provide the interface
+ # and on some archs it is disabled by default causing a mismatch between the
+ # API and the ABI, bug #418253
+ --enable-cxx-exceptions
+ --enable-coredump
+ --enable-ptrace
+ --enable-setjmp
+ $(use_enable debug-frame)
+ $(use_enable doc documentation)
+ $(use_enable lzma minidebuginfo)
+ $(use_enable static-libs static)
+ $(use_enable zlib zlibdebuginfo)
+ # conservative-checks: validate memory addresses before use; as of 1.0.1,
+ # only x86_64 supports this, yet may be useful for debugging, couple it with
+ # debug useflag.
+ $(use_enable debug conservative_checks)
+ $(use_enable debug)
+ $(use_enable test tests)
+ )
+
+ export ac_cv_header_atomic_ops_h=$(usex libatomic)
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ # bug #586208
+ CCACHE_NODIRECT=1 default
+}
+
+multilib_src_test() {
+ # Explicitly allow parallel build of tests.
+ # Sandbox causes some tests to freak out.
+ SANDBOX_ON=0 emake check
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name "*.la" -type f -delete || die
+
+ # If USE=doc, there'll be newly generated docs which we install instead.
+ if ! use doc && [[ ${LIBUNWIND_DOCS_PREBUILT} == 1 ]] ; then
+ doman "${WORKDIR}"/${PN}-${LIBUNWIND_DOCS_VERSION}-docs/man*/*.[0-8]
+ fi
+}
diff --git a/sys-libs/llvm-libunwind/Manifest b/sys-libs/llvm-libunwind/Manifest
index 88df7fa5ce3e..0a7c752dbcfc 100644
--- a/sys-libs/llvm-libunwind/Manifest
+++ b/sys-libs/llvm-libunwind/Manifest
@@ -2,7 +2,7 @@ DIST llvm-gentoo-patchset-13.0.1.tar.xz 6288 BLAKE2B 899222b962486e924e4f8a2b574
DIST llvm-project-14.0.6.src.tar.xz 105618228 BLAKE2B ee67c5407df8cef493b9c0004f15e428f22a536a17e5f4e3eb29a003b8a8ec0abe0fa3e072591161d5f30ef7d8867c1ce34d1b341ad858e93c00263499941a99 SHA512 6fc6eeb60fac698702d1aac495fc0161eb7216a1f8db2020af8fccec5837831f7cc20dc2a169bf4f0b5f520748280b4a86621f3697d622aa58faaa45dbfaad13
DIST llvm-project-14.0.6.src.tar.xz.sig 566 BLAKE2B cb658ad43d8ab6c43a5773aedadf0569c97b5ee4b1bd58eceb10e1879a30880c741c3d66bedd462c892309b688fb7b2673115a62d1f74d71ee375a578de9547f SHA512 b4a7b368532a7a4a24376cfa7db8f6d3478f6d4446474342fc00b474ecf466330cd0f16783209263c4c72d5fc7ddedfb11b95578842e700cfb7ee0bb34cc95d6
DIST llvmorg-13.0.1.tar.gz 147290251 BLAKE2B 2a44b012a672501761d0c27c6b3a315b69bfef0cd13b078a7e7d2fccc4a9c8c0f2bee0f164c4271c9106b0a99cb06e8b64986f66253b613336719fb86b82541b SHA512 9a8cb5d11964ba88b7624f19ec861fb28701f23956ea3c92f6ac644332d5f41fde97bd8933dd3ee70ed378058c252fa3a3887c8d1af90d219970c2b27691166f
-EBUILD llvm-libunwind-13.0.1.ebuild 3810 BLAKE2B c215ba47340bda6a466f6ffcdf978d0d3ab4f4f1f456114f854f53dd3dd04d197ee235c4623d0a3d6e0f26022fef909be2ad04e93679ce357c396c94dc7d3a49 SHA512 96827c5f5838898ac368b79677b6e17fb0545a6a5239f8262622034843777ad4f071f9f80e3c33e0e1a2df334abcefbd7e867c5957d2bf72a1b8416b5b7ac714
-EBUILD llvm-libunwind-14.0.6.ebuild 3199 BLAKE2B 2ca75082a1708903e4a83cba6c526934e324f3a5886b4ebe31db53daf4ba9e0e07b975c7471f5f3a51fac4ca67ad63731635031e0438a8329ad00158954dc58b SHA512 0d65b118e2876d6a8f9c3c5898f41a5d10e5d042f2277be390df7c03c9aff5529e5af3e0004d3d3be5261894a2eaa486266d0be710eeea385b20ba588c0d62cf
-EBUILD llvm-libunwind-15.0.0.9999.ebuild 3021 BLAKE2B be3b0ee26470c838caee43b7dbfcba897af644a586d87bce92833f988f3f5496b9b30da32e33cd29c214be4c3786babd9c890add057d470f09ca6c4493a1d11d SHA512 a353f815c9a2f467d643793777954eb8b5b4cf07a94d1315913b80961c52613351273e24e5aacae02c91993702d6cd3ac221264f009e031ad6ad83e722764115
+EBUILD llvm-libunwind-13.0.1.ebuild 3814 BLAKE2B 90b96e50590839f5bcc8e9d47219e0a6af25c23fd7a6851316596960c00481fbbd02ae606092d79f15648cfb511be9ce44cfec8bb3f185e098eb4eb6bec1c0da SHA512 ee5d861f886d8e33946056ac14a838788dcca42f9e3879fee79f7a211fa2b4eb4481b0f61ec1c77c9b41c9be97ded6fa4e32f63c35bd6ea2a28d0bc503f7ba29
+EBUILD llvm-libunwind-14.0.6.ebuild 3203 BLAKE2B 8ae5c78793e1a71e5f884666d2248bf0495342c4e8bdd80a4fab994e0d46c561790f9dfab32a6d04007dbbe60e5be7b3aa858f379a10f57d6fed3e2e43efc839 SHA512 1065bb6669a83d982e901f50701daf16bd4ae776e0c858fdcfec96c5d41f3a87c7cf53634b6a391422664839e264b9df96752d88054085a498ba718294becc16
+EBUILD llvm-libunwind-15.0.0.9999.ebuild 3025 BLAKE2B d5d6b962382b7c52ca4b95f81d2f3ebb38e35ed646653b0a277abdb53da4d88f195f7fb0dce10e46bc85b20815bebc26ded2aeacb962240c9e70ee6864305416 SHA512 caec661ab8860c6f992b41415f8d9ff215e5c2f95f3b446a2807ffe6ad59c686ef14b3d94f996cb1e090d4e8c49d1fcff67f7ee13b2d751c95adeea8fc78f26e
MISC metadata.xml 438 BLAKE2B 2a36fbbc59e137056029c62aef6d167d9c82531c2582d7bad5cb13cc36e5c4c9518ffe8c56d06bbcfd97ad22eda71a8b776f3984195f53d06cf45659b438dc00 SHA512 4f18b054072d00e5440faa31a59f9ef587d035b5f25e30913f0b1449debee967fa794fae2548e87db3fb2177ce853ab075e1f11f3cc763f5d7fdf06147108845
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.ebuild
index 56489f0dfe52..844bef25c084 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-13.0.1.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python3_{8..10} )
inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="C++ runtime stack unwinder from LLVM"
-HOMEPAGE="https://github.com/llvm-mirror/libunwind"
+HOMEPAGE="https://llvm.org/docs/ExceptionHandling.html"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.6.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.6.ebuild
index a2b5d0e6cd04..f077bc5f0fe5 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.6.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.6.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python3_{8..10} )
inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="C++ runtime stack unwinder from LLVM"
-HOMEPAGE="https://github.com/llvm-mirror/libunwind"
+HOMEPAGE="https://llvm.org/docs/ExceptionHandling.html"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
index dc3e0d055af3..2abe825b0946 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-15.0.0.9999.ebuild
@@ -9,7 +9,7 @@ inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
toolchain-funcs
DESCRIPTION="C++ runtime stack unwinder from LLVM"
-HOMEPAGE="https://github.com/llvm-mirror/libunwind"
+HOMEPAGE="https://llvm.org/docs/ExceptionHandling.html"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"