summaryrefslogtreecommitdiff
path: root/sys-power/intel-undervolt
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/intel-undervolt')
-rw-r--r--sys-power/intel-undervolt/Manifest1
-rw-r--r--sys-power/intel-undervolt/intel-undervolt-9999.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/sys-power/intel-undervolt/Manifest b/sys-power/intel-undervolt/Manifest
index 7293bca1a493..f2b72d56cd52 100644
--- a/sys-power/intel-undervolt/Manifest
+++ b/sys-power/intel-undervolt/Manifest
@@ -1,4 +1,3 @@
DIST intel-undervolt-1.7.tar.gz 31481 BLAKE2B 0daade381b492184616356f097de32d14c76d6ab3f7dd59240fb25f92ee1b9aebb16cbef8b6836e16e361a9560b000655470140c31b5822fed7bd90e0b9d9bf2 SHA512 727eddd47a92f6092e89f9326c6b453785fac6155f2c2c50887f9a90704226e6abaf27b4a91cabd4783c4477371699a92186fe7847ac9218da9c26fb295a5304
EBUILD intel-undervolt-1.7-r1.ebuild 1288 BLAKE2B cc7600305629b0cf69107a0817eb7c2d1c9d65ab4173141ff9041255f5f119d01a588287054753fbadc6c816e8acdc37bc189c96a50e01386ec52d67404b02c4 SHA512 9203e30fc2b0e37232148f777324987a005b4a648b4086c67e3a2506c3d7035e7bc92ec44be0f91120d56f6fbc8c5da6383cd949b2573f61f1ecef7e8a6e7d5d
-EBUILD intel-undervolt-9999.ebuild 1288 BLAKE2B cc7600305629b0cf69107a0817eb7c2d1c9d65ab4173141ff9041255f5f119d01a588287054753fbadc6c816e8acdc37bc189c96a50e01386ec52d67404b02c4 SHA512 9203e30fc2b0e37232148f777324987a005b4a648b4086c67e3a2506c3d7035e7bc92ec44be0f91120d56f6fbc8c5da6383cd949b2573f61f1ecef7e8a6e7d5d
MISC metadata.xml 356 BLAKE2B 22c12ccf85f7527222e159bc4b625db43978a15dfb87a25c63ad58d7319d0008c9fcf809273e94e74108155a64ac702b2e61481b0566f99d1da5f6b353c05b4e SHA512 bd62ea205e920df3426fe93bab565c491f8c4df43c2f8e503a7ffa3972d962caeedba545fe3b9389a82de789839356ad9e92c75f9b0919a91a4ddb51025d35eb
diff --git a/sys-power/intel-undervolt/intel-undervolt-9999.ebuild b/sys-power/intel-undervolt/intel-undervolt-9999.ebuild
deleted file mode 100644
index 6390ac5c14d9..000000000000
--- a/sys-power/intel-undervolt/intel-undervolt-9999.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info systemd toolchain-funcs
-
-DESCRIPTION="Intel CPU undervolting and throttling configuration tool"
-HOMEPAGE="https://github.com/kitsunyan/intel-undervolt"
-
-if [ ${PV} == "9999" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/kitsunyan/${PN}.git"
-else
- SRC_URI="https://github.com/kitsunyan/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="-* ~amd64"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="elogind"
-
-DEPEND="elogind? ( sys-auth/elogind )"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="virtual/pkgconfig"
-
-CONFIG_CHECK="~INTEL_RAPL ~X86_MSR"
-
-src_configure() {
- local myconf=(
- # it's a non-standard build system
- $(usex elogind --enable-elogind '')
- $(usex elogind --eloginddir="${EPREFIX}/$(get_libdir)/elogind" '')
- --enable-openrc
- --enable-systemd
- --unitdir="$(systemd_get_systemunitdir)"
- )
-
- econf "${myconf[@]}"
-}
-
-src_compile() {
- tc-export CC
-
- local myemakeargs=(
- CC="${CC}"
- CFLAGS="${CFLAGS}"
- )
-
- emake "${myemakeargs[@]}"
-}
-
-pkg_postinst() {
- for v in ${REPLACING_VERSIONS}; do
- if [[ ${v} == 1.6 ]] ; then
- elog "openrc service has been renamed to intel-undervolt-loop"
- elog "please update your startup configuration"
- fi
- done
-}