summaryrefslogtreecommitdiff
path: root/sys-process/btop
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/btop')
-rw-r--r--sys-process/btop/Manifest2
-rw-r--r--sys-process/btop/btop-1.4.1.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-process/btop/Manifest b/sys-process/btop/Manifest
index 81d4f7fb0e3b..15e4132abd34 100644
--- a/sys-process/btop/Manifest
+++ b/sys-process/btop/Manifest
@@ -1,5 +1,7 @@
DIST btop-1.3.2.tar.gz 1144620 BLAKE2B dfe351fff0b9e0aa376ebc93d76e1542a1cd93eec695bc9056cd296a11d563d676a0f0a61e911d20cbbaef276feb5bf20cafbc5f063475393b82139e0d08386a SHA512 9bbe983aa1336566f78396b829d49c22fe709e4e3d959dabc7524b61defba2638f3b0c50658f755fd1f02dd70572c78cc3cfc8b01772e174d0f34a48e4e178b2
DIST btop-1.4.0.gh.tar.gz 1239400 BLAKE2B 360b56fc0dab9bc017a4971ffe32cdbe2939b09949f0b4e1d12de5c7b91e6c540d1837c12184b298e35d26c972928d9dd2ef454dbac6464480f3f3e13123545d SHA512 7b7c63daf68192893ae4533c04ea70dcd6f253e188b1c842f2ebebac0b28e51431edef6ccfce5b25b3adbd5b2b637fc832bce7d5d64d664c2bf5c4672be75c8f
+DIST btop-1.4.1.gh.tar.gz 1245448 BLAKE2B cc6be5978da81b1170bf4864ebd6ef352436dbcacf8216780b27af04903b971da4a41d93e992470b3b470c34a414296e0bfd5cad7f431eb9a97a12e48557a008 SHA512 c13bc2d7646b8050283fcfe0a5e7b901284ec08be05d917c0bbc55d92e3d4350f06b164d69b1ad3501805972848ea567074f449b5e2f2ec06e186134487a02d0
EBUILD btop-1.3.2.ebuild 1170 BLAKE2B 69abc3d9e2248f673230b97869df452c980ca8b53fc394f3313149bd0ef14b512d3c92950d9080463d1bd007e0142f73e977c874273e7732701f0f651aa48028 SHA512 5dfbeb3ea95f0dc524e679ee1d23e4d997a4fe4ece61a1374b3c1100e7514ceacb2e7e461befe20952346fe4af837d333b0f84dd65163677d4330700530f30e4
EBUILD btop-1.4.0.ebuild 1336 BLAKE2B 9d47f23616059fb17cf9e548bee573e689050b3ba909faef54dea467b898e2506ff8656d6e4f0a885d7647bf8f83b3437bf0af912c20a7e5233debc3dbbde3d2 SHA512 bbb6a308076e9d6b80bea9d2626c6db45ad8348722930fdeaaad88529023e6f08880536d29a71878fa57e48f4ef1b97f35560c404d8a9ab6b5cdefd56bbe81c6
+EBUILD btop-1.4.1.ebuild 1316 BLAKE2B 4db075dd5a47a39128107a241c46e6e287cbf9264b7c7ddd0a31e2447d148e301a5ffb070c66a8d19bd93a0d1260d8447944e32109fc952639025219b4bc060f SHA512 3c8231c2c08d89e8f389edb0cf5c0e45d4dfd44c8563026d659ca8601e48703bad84e6a246117b86cc530517cc4a9e771be87396eb7a5324c67fe33c4a2c47d7
MISC metadata.xml 548 BLAKE2B 74762cdc63011b363a4c06de8190541f862d70f0006461c7a1cf2d734caf20601ba0769dc067e261957fe42a64bdaf26297bf3d080c3c08203eabd73165f2f8c SHA512 bb16944df9321001ca5c9e9fff49ea39069386117f0cfde67e8f19e3f44c13d360effb578d2c44c67f792d1ff574830f13cb9ef183f594e39ad3669083f2cf41
diff --git a/sys-process/btop/btop-1.4.1.ebuild b/sys-process/btop/btop-1.4.1.ebuild
new file mode 100644
index 000000000000..0bda46b7d2d2
--- /dev/null
+++ b/sys-process/btop/btop-1.4.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2021-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake optfeature toolchain-funcs xdg
+
+DESCRIPTION="A monitor of resources"
+HOMEPAGE="https://github.com/aristocratos/btop"
+SRC_URI="
+ https://github.com/aristocratos/btop/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ app-text/lowdown
+"
+
+DOCS=( "README.md" "CHANGELOG.md" )
+
+pkg_setup() {
+ if [[ "${MERGE_TYPE}" != "binary" ]]; then
+ if tc-is-clang ; then
+ if [[ "$(clang-major-version)" -lt 16 ]]; then
+ die "sys-process/btop requires >=llvm-core/clang-16.0.0 to build."
+ fi
+ elif ! tc-is-gcc ; then
+ die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc or >=llvm-core/clang-16.0.0 instead."
+ fi
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBTOP_GPU=true
+ -DBTOP_RSMI_STATIC=false
+ -DBTOP_STATIC=false
+ # These settings can be controlled in make.conf CFLAGS/CXXFLAGS
+ -DBTOP_LTO=false
+ -DBTOP_WERROR=false
+ -DBTOP_USE_MOLD=false
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "GPU monitoring support (Radeon GPUs)" dev-util/rocm-smi
+ optfeature "GPU monitoring support (NVIDIA GPUs)" x11-drivers/nvidia-drivers
+}