summaryrefslogtreecommitdiff
path: root/sys-process/iotop-c/iotop-c-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/iotop-c/iotop-c-9999.ebuild')
-rw-r--r--sys-process/iotop-c/iotop-c-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-process/iotop-c/iotop-c-9999.ebuild b/sys-process/iotop-c/iotop-c-9999.ebuild
index b05952298d1d..47a5c48a0a0e 100644
--- a/sys-process/iotop-c/iotop-c-9999.ebuild
+++ b/sys-process/iotop-c/iotop-c-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,6 +23,11 @@ FILECAPS=(
cap_net_admin=eip usr/bin/iotop
)
+src_prepare() {
+ sed -e 's/-D_FORTIFY_SOURCE=2//' -i Makefile || die
+ default
+}
+
src_compile() {
emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
}