summaryrefslogtreecommitdiff
path: root/sys-process
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/Manifest.gzbin9977 -> 9982 bytes
-rw-r--r--sys-process/htop/Manifest2
-rw-r--r--sys-process/htop/htop-3.2.2.ebuild113
-rw-r--r--sys-process/iotop/Manifest2
-rw-r--r--sys-process/iotop/iotop-0.6_p20230124.ebuild37
5 files changed, 154 insertions, 0 deletions
diff --git a/sys-process/Manifest.gz b/sys-process/Manifest.gz
index e73fe02f78fa..35d688381a4f 100644
--- a/sys-process/Manifest.gz
+++ b/sys-process/Manifest.gz
Binary files differ
diff --git a/sys-process/htop/Manifest b/sys-process/htop/Manifest
index 5e1983e837fd..e3ce1c2715dc 100644
--- a/sys-process/htop/Manifest
+++ b/sys-process/htop/Manifest
@@ -1,4 +1,6 @@
DIST htop-3.2.1.tar.xz 406048 BLAKE2B 7addefca7de8f0867220e6415f4585f7e6ecf655d6245e4a8e120552ac738544fde1c2d8e24ce1139209caad23994316e8be9611f6ed0253d60547158d17ff24 SHA512 f412c10ebdec4fb026fb93a79a9b0b84612ad5a0d28e37f06713e6c895f70e92cbd09a8737d04f3d51102295d7a419eb2c3ec3907b96f553fda8ff3d1a2142b6
+DIST htop-3.2.2.tar.xz 384820 BLAKE2B da3b4aea4e5d32d4b432e0f45089e7795b59d9a947dc4af76cb6b7f9137e6d45901c8169c8d2c796a3f43162c1e3c8f1e18bd17f20750637e06fe4c3ebe22caa SHA512 59f3f06677076262e25a478552e4438ce37028e2f064d3fb78653d3213b48ae4d78c7e0d62ee785a4ed3c6c99b7faafd9afab94c4350a4e5c5843cef81aaf489
EBUILD htop-3.2.1-r2.ebuild 2565 BLAKE2B 823ca343ccac450f67019718ab558eac8b3e8f9363f041cbb69bf33763488b8fc884f1719e1055cfdb36ab87b1d58c6c620a037c0c800cd37abe46cfc43fdbfa SHA512 1c9a97e27b60bdcd7562bd7026d700f9c91b4d8e851c22aba56f5d4e8aca34e0b767d0cc5b2402a3b116621bf91ee043f5c487346663e29bd3064576ca38c06f
+EBUILD htop-3.2.2.ebuild 2573 BLAKE2B 454d02e6b1cdc7312d4fe1103f034485dd40cfe7526081db977f10eb236d79cce361c5a7da8f222dc29590f9f91e00387265535c98efdcc1b2151db7f7d82e8b SHA512 7d0e860dae4b0d372e42276cbc103cbf0bf861fc5dd770592f5eae873e115ada69d730ac919e680fbc45b258db90e2d575fd2332cce676cdd63a4b2f44baf51c
EBUILD htop-9999.ebuild 2573 BLAKE2B 454d02e6b1cdc7312d4fe1103f034485dd40cfe7526081db977f10eb236d79cce361c5a7da8f222dc29590f9f91e00387265535c98efdcc1b2151db7f7d82e8b SHA512 7d0e860dae4b0d372e42276cbc103cbf0bf861fc5dd770592f5eae873e115ada69d730ac919e680fbc45b258db90e2d575fd2332cce676cdd63a4b2f44baf51c
MISC metadata.xml 908 BLAKE2B ef2166ceae63ee1545ac919278b3c0e2bcbba9612d7ff6e6cac20c3d1b5981b49bb13894b8177caafcc844395ae373415a07726ad89dabc4328274eec39ae90a SHA512 8f13f80bc6bdbfbf23e7172e1872681d7f063094a68a8e773a9258e364bb947d16325cf26e5091b3b75c80b0f3b8444394535bbe409e95d7e97a733e09d5537e
diff --git a/sys-process/htop/htop-3.2.2.ebuild b/sys-process/htop/htop-3.2.2.ebuild
new file mode 100644
index 000000000000..7080f7e4ba08
--- /dev/null
+++ b/sys-process/htop/htop-3.2.2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+# We avoid xdg.eclass here because it'll pull in glib, desktop utils on
+# htop which is often used on headless machines. bug #787470
+inherit linux-info optfeature python-any-r1 xdg-utils
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/htop-dev/htop.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/htop-dev/htop/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+fi
+
+S="${WORKDIR}/${P/_}"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+IUSE="caps debug delayacct hwloc lm-sensors llvm-libunwind openvz unicode unwind vserver"
+
+RDEPEND="
+ sys-libs/ncurses:=[unicode(+)?]
+ hwloc? ( sys-apps/hwloc:= )
+ unwind? (
+ !llvm-libunwind? ( sys-libs/libunwind:= )
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ )
+ kernel_linux? (
+ caps? ( sys-libs/libcap )
+ delayacct? ( dev-libs/libnl:3 )
+ lm-sensors? ( sys-apps/lm-sensors )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog README )
+
+CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ if [[ ${CBUILD} != ${CHOST} ]] ; then
+ # bug #328971
+ export ac_cv_file__proc_{meminfo,stat}=yes
+ fi
+
+ local myeconfargs=(
+ --enable-unicode
+ $(use_enable debug)
+ $(use_enable hwloc)
+ $(use_enable !hwloc affinity)
+ $(use_enable openvz)
+ $(use_enable unicode)
+ $(use_enable unwind)
+ $(use_enable vserver)
+ )
+
+ if use kernel_linux ; then
+ myeconfargs+=(
+ $(use_enable caps capabilities)
+ $(use_enable delayacct)
+ $(use_enable lm-sensors sensors)
+ )
+ else
+ if use kernel_Darwin ; then
+ # Upstream default to checking but --enable-affinity
+ # overrides this. Simplest to just disable on Darwin
+ # given it works on BSD anyway.
+ myeconfargs+=( --disable-affinity )
+ fi
+
+ myeconfargs+=(
+ --disable-capabilities
+ --disable-delayacct
+ --disable-sensors
+ )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ optfeature "Viewing processes accessing certain files" sys-process/lsof
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
diff --git a/sys-process/iotop/Manifest b/sys-process/iotop/Manifest
index 15063c183b09..5f4315c6d118 100644
--- a/sys-process/iotop/Manifest
+++ b/sys-process/iotop/Manifest
@@ -3,5 +3,7 @@ AUX iotop-0.6-Ignore-invalid-lines-in-proc-status-files.patch 2826 BLAKE2B bef78
AUX iotop-0.6-Only-split-proc-status-lines-on-the-character.patch 984 BLAKE2B c43a4feaa7293b86454a96aaddbbc3c40c6a2afc2656448cc899230abc479d702adbc5785a818754214f7524bc499f4699ac1c841b7753601c9bcd89771440ec SHA512 291ed55dcebd988e0819f28805f12392bfff3ea0686cddebdb9bec8042f981c2d94c7ac3f8d9a4ba5e8611686129c47347bd1a9484ce82a2687c651007efb937
AUX iotop-0.6-setup.py3.patch 1151 BLAKE2B da00d36a1778173e2d77041fec584aa1ff42062932915ff2a6beb9aaeda0699fdb6a6c9903eee56e10efb9ed9d6def08a8d7fbbe714def4e8bff4504500aa55e SHA512 6b97da5ef9e78c268193ce0270328f4c4d99d30f532fe68dac9bd033bb0a5e6cdb3145b53a7670c7babdae7f170473d1f9eb23137b5950fdaceadde266b4bb73
DIST iotop-0.6.tar.bz2 29779 BLAKE2B 6c979f7beef4e9ec6536eb5ec113ab7089ccb0b8b00dfca6181408390584dac0eae18b110c3f4837a25defd7ab2c2e9d79f1f5cad762f97519e94847951f0037 SHA512 b1047da3bc46604447cc8ab22442a3a5381e1a79a6b176fe9ee8402ee5cebb959205407a6aeaffccccde9d2f67624ff8ee6717b051838f13ab88bf3a16db3ab9
+DIST iotop-0.6_p20230124.tar.gz 28751 BLAKE2B 4fd281b663288825a3315442171df649b59a133479732367863e4f0d75f81e760af5117aec7b1ff070bb7a98e7348f76a6490b9ab8866c0ff7cb52073b07fbd8 SHA512 916809c9a97ed260525b00b4e6bd1f55f07b307bf1dc2f61e87317014d04e1bb3fab03c9ad9d5c110d198fbc89427cbe9e6679f03785f71e7e572f985dbac2a7
EBUILD iotop-0.6.ebuild 987 BLAKE2B 2194469ff0bb7858611c7c7ffa57cd2df933219a777abd10c0607d09be51e36dc06f988dda4cf17dedc1f7439d5fbe1aed8454caed4c432a9c816030707c16a2 SHA512 997b2f7f373c678df96f7e40c774031e025121e24222bb5e798702ab7fe7896974da1ae49f8a31d0338dfe43d7ba79c42a59a70fde0791e845e04e5fb4d145a7
+EBUILD iotop-0.6_p20230124.ebuild 1146 BLAKE2B 42bc3e816652b3c0bba8f3f21c82e27ef4be4ce967aa1944172f88af0ac3ed16da0f49f151f476d53424eda421f6d1982ad13759760e8aa82f4a19ea00a9409b SHA512 63c260db4ba1a79b7a77546e1c350b4c9e3d40a843c0b908570f6b8b38b26138847472423e70719ab5d265ebc88b6e7c3c015aaa753df5022267e15c4f99b643
MISC metadata.xml 360 BLAKE2B 7d33d33cef4bf209ff0b3a487cfd95d89f2143f1f300ad8984a414d19d016c8bfc06433cc6d2bce662c04e97659391e113d45fccd9d1b51c3409969d94a70cc3 SHA512 f89ebbe23e0d3ca111fde959b313c09e49c4daaea2cc433dc3424cbf90f9a4d7e2b4bf6019edf95345a053d437aa1d8809cd22e9ce5fe030967ee3befa428692
diff --git a/sys-process/iotop/iotop-0.6_p20230124.ebuild b/sys-process/iotop/iotop-0.6_p20230124.ebuild
new file mode 100644
index 000000000000..4f33df9d6d78
--- /dev/null
+++ b/sys-process/iotop/iotop-0.6_p20230124.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="ncurses(+)"
+
+MY_COMMIT="a14256a3ff74eeee59493ac088561f1bafab85a7"
+inherit distutils-r1 linux-info
+
+DESCRIPTION="Top-like UI used to show which process is using the I/O"
+HOMEPAGE="http://guichaz.free.fr/iotop/"
+SRC_URI="https://repo.or.cz/iotop.git/snapshot/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT::7}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="!sys-process/iotop-c"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+DOCS=( NEWS README THANKS )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+pkg_postinst() {
+ ewarn "Since Linux 5.14, sysctl kernel.task_delayacct should be enabled"
+ ewarn "This can be enabled by running: 'sysctl kernel.task_delayacct=1' "
+ ewarn "And can be made persistent by adding 'kernel.task_delayacct = 1' to ${EROOT}/etc/sysctl.conf"
+}