summaryrefslogtreecommitdiff
path: root/virtual/wine/wine-0-r9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/wine/wine-0-r9.ebuild')
-rw-r--r--virtual/wine/wine-0-r9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/virtual/wine/wine-0-r9.ebuild b/virtual/wine/wine-0-r9.ebuild
new file mode 100644
index 000000000000..b46e61f831a1
--- /dev/null
+++ b/virtual/wine/wine-0-r9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Virtual for Wine that supports multiple variants and slotting"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+abi_x86_32 +abi_x86_64 staging"
+
+REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
+
+# Note, the ordering here is intentional, to take advantage of the short-circuit
+# logic of portage, to enforce wine-vanilla as default for new users. The idea
+# behind this is that some USE flags may pull in 3rd-party patchsets, so default
+# of vanilla prevents that.
+RDEPEND="
+ staging? ( || (
+ app-emulation/wine-staging[staging(+)]
+ ) )
+ || (
+ app-emulation/wine-vanilla[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-staging[abi_x86_32=,abi_x86_64=]
+ )"