summaryrefslogtreecommitdiff
path: root/www-apache
diff options
context:
space:
mode:
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/Manifest.gzbin5571 -> 5732 bytes
-rw-r--r--www-apache/mod_tls/Manifest3
-rw-r--r--www-apache/mod_tls/metadata.xml11
-rw-r--r--www-apache/mod_tls/mod_tls-0.14.0.ebuild40
4 files changed, 54 insertions, 0 deletions
diff --git a/www-apache/Manifest.gz b/www-apache/Manifest.gz
index dcd064eac519..541f91c3b82e 100644
--- a/www-apache/Manifest.gz
+++ b/www-apache/Manifest.gz
Binary files differ
diff --git a/www-apache/mod_tls/Manifest b/www-apache/mod_tls/Manifest
new file mode 100644
index 000000000000..eece49b0ba09
--- /dev/null
+++ b/www-apache/mod_tls/Manifest
@@ -0,0 +1,3 @@
+DIST mod_tls-0.14.0.tar.gz 206639 BLAKE2B fffdb26b171cba674c283e689728dc42fff75124c0a1e2590c31e0fea2d5ea840db4cdbaa5455eee46c1cdd5211532b80271c2cf63f98c246e34bda07d96508d SHA512 a48e0eba706358aa348b3feba84392b9ac43979f40ae4eb56b1a4cc9b3bf39c233cafa166edb193a3c20657d7c9f592941ac19b22852516d34d956586390c7c7
+EBUILD mod_tls-0.14.0.ebuild 768 BLAKE2B 81fbdcbe4f08eaff1aec51ef169c1a215b28080551bbd962769ad49568dbc3272ec3e7b1627c360ae2bfd96dd5d82aa47601fcd97b1b35961235761bf3c925c3 SHA512 be2b5adc37cb857c2e7cd5d8f77e39f4f606c69e19ca6c0572bddab7aab0a48f313e762c221e83c2322b4de93d10b8d5834342166f6df1b228810fc5606673c5
+MISC metadata.xml 342 BLAKE2B 197221ff43382e2032c19980cea3f54346b73df85e89f0dd66ee357c21a7c003fc06b71dc3f6843176afec734b559195366bfc9d7e430726f8a5b1f1dfad66e0 SHA512 042ef668061cc8e732e376aa6e01676b04932532d51b85be00beabaa427742544333d38c0f534ca60c5ef2f8fd9fbc6ca5d290fdb804774e3c414dddea06426a
diff --git a/www-apache/mod_tls/metadata.xml b/www-apache/mod_tls/metadata.xml
new file mode 100644
index 000000000000..f536232054b7
--- /dev/null
+++ b/www-apache/mod_tls/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>apache-bugs@gentoo.org</email>
+ <name>Apache project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">icing/mod_tls</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apache/mod_tls/mod_tls-0.14.0.ebuild b/www-apache/mod_tls/mod_tls-0.14.0.ebuild
new file mode 100644
index 000000000000..002b3e5f85fe
--- /dev/null
+++ b/www-apache/mod_tls/mod_tls-0.14.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit apache-module autotools
+
+DESCRIPTION="A module that uses rustls to provide a memory safe TLS implementation in Rust."
+HOMEPAGE="https://github.com/icing/mod_tls"
+SRC_URI="https://github.com/icing/mod_tls/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ssl"
+
+RDEPEND="
+ =net-libs/rustls-ffi-0.14*
+ >=www-servers/apache-2.4.48[-apache2_modules_tls(-)]
+"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="TLS"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_tls.conf" "41_mod_tls.conf"
+}