summaryrefslogtreecommitdiff
path: root/www-apps/cvsweb/cvsweb-3.0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/cvsweb/cvsweb-3.0.5.ebuild')
-rw-r--r--www-apps/cvsweb/cvsweb-3.0.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-apps/cvsweb/cvsweb-3.0.5.ebuild b/www-apps/cvsweb/cvsweb-3.0.5.ebuild
new file mode 100644
index 000000000000..04e2333ac8f0
--- /dev/null
+++ b/www-apps/cvsweb/cvsweb-3.0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit webapp
+
+DESCRIPTION="WWW interface to a CVS tree"
+HOMEPAGE="http://www.freebsd.org/projects/cvsweb.html"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/scop/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8
+ >=dev-vcs/cvs-1.11
+ >=dev-vcs/rcs-5.7
+ >=dev-perl/URI-1.28
+ dev-perl/IPC-Run
+ dev-perl/MIME-Types
+ dev-perl/String-Ediff
+ >=dev-vcs/cvsgraph-1.4.0
+ >=app-text/enscript-1.6.3"
+
+src_install() {
+ webapp_src_preinst
+
+ cp cvsweb.conf "${D}"/${MY_HOSTROOTDIR}
+ cp css/cvsweb.css "${D}"/${MY_HTDOCSDIR}
+ exeinto ${MY_CGIBINDIR}
+ doexe cvsweb.cgi
+ chmod +x "${D}"/${MY_CGIBINDIR}/cvsweb.cgi
+
+ dodoc README TODO NEWS ChangeLog
+
+ webapp_hook_script "${FILESDIR}"/reconfig
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}