summaryrefslogtreecommitdiff
path: root/www-apps/nikola/nikola-7.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/nikola/nikola-7.2.0.ebuild')
-rw-r--r--www-apps/nikola/nikola-7.2.0.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/www-apps/nikola/nikola-7.2.0.ebuild b/www-apps/nikola/nikola-7.2.0.ebuild
deleted file mode 100644
index 782d8c1d45d3..000000000000
--- a/www-apps/nikola/nikola-7.2.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
-inherit distutils-r1
-
-DESCRIPTION="A static website and blog generator"
-HOMEPAGE="https://getnikola.com/"
-MY_PN="Nikola"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-2
- EGIT_REPO_URI="https://github.com/ralsina/${PN}.git"
-else
- SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${P}.tar.gz"
- KEYWORDS="amd64"
-fi
-
-LICENSE="MIT-with-advertising Apache-2.0" # Gutenberg
-SLOT="0"
-IUSE="assets charts hyphenation ipython jinja markdown"
-RESTRICT="test" # needs freezegun, coveralls, and phpserialize
-
-DEPEND=">=dev-python/docutils-0.12[${PYTHON_USEDEP}]" # needs rst2man to build manpage
-RDEPEND="${DEPEND}
- >=dev-python/blinker-1.3[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- >=dev-python/doit-0.23.0[${PYTHON_USEDEP}]
- >=dev-python/logbook-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-3.3.5[${PYTHON_USEDEP}]
- >=dev-python/mako-1.0[${PYTHON_USEDEP}]
- >=dev-python/natsort-3.3.0[${PYTHON_USEDEP}]
- >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
- >=dev-python/PyRSS2Gen-1.1[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.2[${PYTHON_USEDEP}]
- >=dev-python/setuptools-5.4.1[${PYTHON_USEDEP}]
- >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/unidecode-0.04.16[${PYTHON_USEDEP}]
- >=dev-python/yapsy-1.10.423[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- assets? ( >=dev-python/webassets-0.10.1[${PYTHON_USEDEP}] )
- charts? ( >=dev-python/pygal-1.5.1[${PYTHON_USEDEP}] )
- hyphenation? ( >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}] )
- ipython? ( >=dev-python/ipython-1.2.1[${PYTHON_USEDEP}] )
- jinja? ( >=dev-python/jinja-2.7.2[${PYTHON_USEDEP}] )
- markdown? ( >=dev-python/markdown-2.4.0[${PYTHON_USEDEP}] )"
-# more options as packages will be added:
-# livereload? ( =dev-python/livereload-2.3.1[${PYTHON_USEDEP}] )
-# micawber? ( >=dev-python/micawber-0.3.0[${PYTHON_USEDEP}] )
-# typogrify? ( >=dev-python/typogrify-2.0.4[${PYTHON_USEDEP}] )
-
-src_install() {
- distutils-r1_src_install
-
- # hackish way to remove docs that ended up in the wrong place
- rm -rf "${D}"/usr/share/doc/${PN}
-
- dodoc AUTHORS.txt CHANGES.txt README.rst docs/*.txt
- doman docs/man/*
-}