summaryrefslogtreecommitdiff
path: root/www-apps/pcgi
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/pcgi')
-rw-r--r--www-apps/pcgi/Manifest4
-rw-r--r--www-apps/pcgi/metadata.xml8
-rw-r--r--www-apps/pcgi/pcgi-2.0_alpha5.ebuild49
3 files changed, 61 insertions, 0 deletions
diff --git a/www-apps/pcgi/Manifest b/www-apps/pcgi/Manifest
new file mode 100644
index 000000000000..af3287389247
--- /dev/null
+++ b/www-apps/pcgi/Manifest
@@ -0,0 +1,4 @@
+DIST PCGI-HOWTO-1998-08-13.html.bz2 6483 BLAKE2B 1283503a0474ad4098a9371842b9db6db5d20cd78952d1ddf79cdd2e2f7e37fe17553bc12f635026b45ef36512fb0d2bd3dbaa2590be0796d00a0854d30b6335 SHA512 8b86e0c166055492564ee919d8f983f8f9df7927aac63f9f63068f5dd837a675c3b230801763d2623401095515fe138b5c9ab222d972bbbcedce36ad1b576d16
+DIST Zope-2.6.1-src.tgz 2318685 BLAKE2B 7be409216124479b0baa1c079bc5f41ed7c5f87318a9f814af9d63b0b87fe51756531dde8b4ba7cb4155f29aaf5c39fe82c4f1bb3a7f8586ab3f149798dae842 SHA512 b714c533f818cbc16bd6c5f899049a4f214d5aad06a98f822f886a33fd5636b416cf8e944757f4a50d39daaac482e2af24dcaf4bc0ab795b9e9d25c961525451
+EBUILD pcgi-2.0_alpha5.ebuild 1460 BLAKE2B 2da4bf8734f5ba07c0ecca190ade239a2cf33a9078975dc2cf44b0341728c9071ad59a67acf6e1a9c64ee2b1d80ec55b12fc0407fbe1504cc6b457d86041ed5f SHA512 f0f4a3c88457e7efc6a676d9d126e2659c4f0c59651f7e26ffaf7df9dd0c40beeae42cfa525d586d2f1f6ff46e034b96c209bf013d85fafe0ca63e445043debe
+MISC metadata.xml 246 BLAKE2B 6bdcea4d16a06756a1ab24fb076af6d88134c134f9239e658b7e5facb8cf6ed2f30d98938fd92bc8a3690e54273fd7f72420ccab04e7a6f7319e257a9f9ed618 SHA512 1181711d3b020b2ca7beae0a539a9b7f1abe70962cd8561900e5f06e14c9c871c61ca6088fb674de19ef3b844a1b3c29cf0f84f638b2d0cb7c030f60cd1d42ed
diff --git a/www-apps/pcgi/metadata.xml b/www-apps/pcgi/metadata.xml
new file mode 100644
index 000000000000..f2f2ba9e2823
--- /dev/null
+++ b/www-apps/pcgi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>web-apps@gentoo.org</email>
+ <name>Gentoo Webapps</name>
+</maintainer>
+</pkgmetadata>
diff --git a/www-apps/pcgi/pcgi-2.0_alpha5.ebuild b/www-apps/pcgi/pcgi-2.0_alpha5.ebuild
new file mode 100644
index 000000000000..788a90272d6a
--- /dev/null
+++ b/www-apps/pcgi/pcgi-2.0_alpha5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+# this package is ONLY available inside the Zope tarball!!!
+ZOPE_PV=2.6.1
+ZOPE_P=Zope-${ZOPE_PV}-src
+S="${WORKDIR}/${ZOPE_P}/pcgi"
+
+# the only real docs about it are on the author's homepage
+# the html.bz2 file is a copy of http://starship.python.net/crew/jbauer/persistcgi/howto/index.html, renamed.
+# this is specifically done as every link I have seen is to the old URL of the
+# author
+DOCDATE="1998-08-13"
+
+MY_PV="${PV/_alpha/a}"
+
+DESCRIPTION="Jeff Bauer's Persistent CGI"
+HOMEPAGE="http://starship.python.net/crew/jbauer/persistcgi/"
+SRC_URI="http://www.zope.org/Products/Zope/${ZOPE_PV}/${ZOPE_P}.tgz
+ mirror://gentoo/PCGI-HOWTO-${DOCDATE}.html.bz2"
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+DEPEND="${DEPEND}"
+RDEPEND="${RDEPEND}
+ dev-lang/python"
+
+src_compile() {
+ econf || die "econf failed"
+ emake all creosote || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ dodir /usr/bin
+ dodoc ${WORKDIR}/CGI-HOWTO-1998-08-13.html
+ newbin pcgi-wrapper pcgi-wrapper${MY_PV}
+ dosym /usr/bin/pcgi-wrapper${MY_PV} /usr/bin/pcgi-wrapper
+ dodoc MrCreosote/README.MrCreosote README Test/README.parseinfo
+ newdoc Util/README README.Util
+ dobin MrCreosote/pcgi-creosote MrCreosote/creosote.py
+ dobin Util/killpcgi.py Util/pcgifile.py
+ dobin pcgi_publisher.py
+ newbin Test/parseinfo pcgi-parseinfo
+ cp -pPR Example ${D}/usr/share/doc/${PF}/
+}