summaryrefslogtreecommitdiff
path: root/www-client/chromium/chromium-110.0.5481.38.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/chromium/chromium-110.0.5481.38.ebuild')
-rw-r--r--www-client/chromium/chromium-110.0.5481.38.ebuild18
1 files changed, 17 insertions, 1 deletions
diff --git a/www-client/chromium/chromium-110.0.5481.38.ebuild b/www-client/chromium/chromium-110.0.5481.38.ebuild
index 030ad228d824..8aaf2bfec27b 100644
--- a/www-client/chromium/chromium-110.0.5481.38.ebuild
+++ b/www-client/chromium/chromium-110.0.5481.38.ebuild
@@ -19,13 +19,19 @@ DESCRIPTION="Open-source version of Google Chrome web browser"
HOMEPAGE="https://chromium.org/"
PATCHSET="4"
PATCHSET_NAME="chromium-$(ver_cut 1)-patchset-${PATCHSET}"
+PATCHSET_URI_PPC64="https://quickbuild.io/~raptor-engineering-public"
+PATCHSET_NAME_PPC64="chromium_110.0.5481.77-1raptor0~deb11u1.debian"
SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}.tar.xz
https://github.com/stha09/chromium-patches/releases/download/${PATCHSET_NAME}/${PATCHSET_NAME}.tar.xz
+ ppc64? (
+ ${PATCHSET_URI_PPC64}/+archive/ubuntu/chromium/+files/${PATCHSET_NAME_PPC64}.tar.xz
+ https://dev.gentoo.org/~sultan/distfiles/www-client/chromium/chromium-ppc64le-gentoo-patches-1.tar.xz
+ )
pgo? ( https://github.com/elkablo/chromium-profiler/releases/download/v0.2/chromium-profiler-0.2.tar )"
LICENSE="BSD"
SLOT="0/beta"
-KEYWORDS="~amd64 ~arm64"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
IUSE="+X component-build cups cpu_flags_arm_neon debug gtk4 +hangouts headless +js-type-check kerberos libcxx lto +official pgo pic +proprietary-codecs pulseaudio qt5 screencast selinux +suid +system-av1 +system-ffmpeg +system-harfbuzz +system-icu +system-png vaapi wayland widevine"
REQUIRED_USE="
component-build? ( !suid !libcxx )
@@ -342,6 +348,16 @@ src_prepare() {
"${FILESDIR}/chromium-cross-compile.patch"
)
+ if use ppc64 ; then
+ local p
+ for p in $(grep -v "^#" "${WORKDIR}"/debian/patches/series | grep "^ppc64le" || die); do
+ if [[ ! $p =~ "fix-breakpad-compile.patch" ]]; then
+ eapply "${WORKDIR}/debian/patches/${p}"
+ fi
+ done
+ PATCHES+=( "${WORKDIR}/ppc64le" )
+ fi
+
default
mkdir -p third_party/node/linux/node-linux-x64/bin || die