summaryrefslogtreecommitdiff
path: root/www-client/chromium/chromium-77.0.3865.90.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/chromium/chromium-77.0.3865.90.ebuild')
-rw-r--r--www-client/chromium/chromium-77.0.3865.90.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/www-client/chromium/chromium-77.0.3865.90.ebuild b/www-client/chromium/chromium-77.0.3865.90.ebuild
index a22e92ceac21..0dbd8e2289d9 100644
--- a/www-client/chromium/chromium-77.0.3865.90.ebuild
+++ b/www-client/chromium/chromium-77.0.3865.90.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 ~x86"
IUSE="+closure-compile component-build cups cpu_flags_arm_neon gnome-keyring +hangouts jumbo-build kerberos pic +proprietary-codecs pulseaudio selinux +suid +system-ffmpeg +system-icu +system-libvpx +tcmalloc widevine"
RESTRICT="!system-ffmpeg? ( proprietary-codecs? ( bindist ) )"
REQUIRED_USE="component-build? ( !suid )"
@@ -154,6 +154,7 @@ PATCHES=(
"${FILESDIR}/chromium-77-no-cups.patch"
"${FILESDIR}/chromium-77-gcc-abstract.patch"
"${FILESDIR}/chromium-77-gcc-include.patch"
+ "${FILESDIR}/chromium-77-gcc-alignas.patch"
)
pre_build_checks() {
@@ -162,6 +163,10 @@ pre_build_checks() {
if tc-is-gcc && ! ver_test "$(gcc-version)" -ge 8.0; then
die "At least gcc 8.0 is required"
fi
+ # component build hangs with tcmalloc enabled due to sandbox issue, bug #695976.
+ if has usersandbox ${FEATURES} && use tcmalloc && use component-build; then
+ die "Component build with tcmalloc requires FEATURES=-usersandbox."
+ fi
fi
# Check build requirements, bug #541816 and bug #471810 .