summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-113.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-113.0.2.ebuild')
-rw-r--r--www-client/firefox/firefox-113.0.2.ebuild38
1 files changed, 27 insertions, 11 deletions
diff --git a/www-client/firefox/firefox-113.0.2.ebuild b/www-client/firefox/firefox-113.0.2.ebuild
index 00e00080656d..d94b3e7a7a51 100644
--- a/www-client/firefox/firefox-113.0.2.ebuild
+++ b/www-client/firefox/firefox-113.0.2.ebuild
@@ -3,9 +3,9 @@
EAPI=8
-FIREFOX_PATCHSET="firefox-113-patches-01.tar.xz"
+FIREFOX_PATCHSET="firefox-113-patches-02.tar.xz"
-LLVM_MAX_SLOT=15
+LLVM_MAX_SLOT=16
PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="ncurses,sqlite,ssl"
@@ -80,15 +80,31 @@ FF_ONLY_DEPEND="!www-client/firefox:0
screencast? ( media-video/pipewire:= )
selinux? ( sec-policy/selinux-mozilla )"
BDEPEND="${PYTHON_DEPS}
- sys-devel/clang:15
- sys-devel/llvm:15
- clang? (
- || (
- sys-devel/lld:15
- sys-devel/mold
+ || (
+ (
+ sys-devel/clang:16
+ sys-devel/llvm:16
+ clang? (
+ || (
+ sys-devel/lld:16
+ sys-devel/mold
+ )
+ virtual/rust:0/llvm-16
+ pgo? ( =sys-libs/compiler-rt-sanitizers-16*[profile] )
+ )
+ )
+ (
+ sys-devel/clang:15
+ sys-devel/llvm:15
+ clang? (
+ || (
+ sys-devel/lld:15
+ sys-devel/mold
+ )
+ virtual/rust:0/llvm-15
+ pgo? ( =sys-libs/compiler-rt-sanitizers-15*[profile] )
+ )
)
- virtual/rust:0/llvm-15
- pgo? ( =sys-libs/compiler-rt-sanitizers-15*[profile] )
)
app-alternatives/awk
app-arch/unzip
@@ -208,7 +224,7 @@ llvm_check_deps() {
return 1
fi
- if use clang && tc-ld-is-lld ; then
+ if use clang && ! tc-ld-is-mold ; then
if ! has_version -b "sys-devel/lld:${LLVM_SLOT}" ; then
einfo "sys-devel/lld:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1