summaryrefslogtreecommitdiff
path: root/www-client/firefox/firefox-115.13.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-115.13.0.ebuild')
-rw-r--r--www-client/firefox/firefox-115.13.0.ebuild51
1 files changed, 10 insertions, 41 deletions
diff --git a/www-client/firefox/firefox-115.13.0.ebuild b/www-client/firefox/firefox-115.13.0.ebuild
index 5890b9ed1acc..67c0548f35c3 100644
--- a/www-client/firefox/firefox-115.13.0.ebuild
+++ b/www-client/firefox/firefox-115.13.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-FIREFOX_PATCHSET="firefox-115esr-patches-11.tar.xz"
+FIREFOX_PATCHSET="firefox-115esr-patches-12.tar.xz"
LLVM_MAX_SLOT=18
@@ -50,16 +50,14 @@ PATCH_URIS=(
https://dev.gentoo.org/~juippis/mozilla/patchsets/${FIREFOX_PATCHSET}
)
-SRC_URI="${MOZ_SRC_BASE_URI}/source/${MOZ_P}.source.tar.xz -> ${MOZ_P_DISTFILES}.source.tar.xz
- ${PATCH_URIS[@]}"
-
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="https://www.mozilla.com/firefox"
-
-KEYWORDS="amd64 arm64 ppc64 ~riscv x86"
-
-SLOT="esr"
+SRC_URI="${MOZ_SRC_BASE_URI}/source/${MOZ_P}.source.tar.xz -> ${MOZ_P_DISTFILES}.source.tar.xz
+ ${PATCH_URIS[@]}"
+S="${WORKDIR}/${PN}-${PV%_*}"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
+SLOT="esr"
+KEYWORDS="amd64 arm64 ppc64 ~riscv x86"
IUSE="+clang cpu_flags_arm_neon dbus debug eme-free hardened hwaccel"
IUSE+=" jack libproxy lto openh264 pgo pulseaudio sndio selinux"
@@ -233,8 +231,6 @@ DEPEND="${COMMON_DEPEND}
x11-libs/libSM
)"
-S="${WORKDIR}/${PN}-${PV%_*}"
-
# Allow MOZ_GMP_PLUGIN_LIST to be set in an eclass or
# overridden in the enviromnent (advanced hackers only)
if [[ -z "${MOZ_GMP_PLUGIN_LIST+set}" ]] ; then
@@ -260,7 +256,8 @@ llvm_check_deps() {
if use pgo ; then
if ! has_version -b "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*[profile]" ; then
- einfo "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*[profile] is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ einfo "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*[profile] is missing!"
+ einfo "Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
fi
@@ -490,8 +487,6 @@ virtwl() {
[[ -n $XDG_RUNTIME_DIR ]] || die "${FUNCNAME} needs XDG_RUNTIME_DIR to be set; try xdg_environment_reset"
tinywl -h >/dev/null || die 'tinywl -h failed'
- # TODO: don't run addpredict in utility function. WLR_RENDERER=pixman doesn't work
- addpredict /dev/dri
local VIRTWL VIRTWL_PID
coproc VIRTWL { WLR_BACKENDS=headless exec tinywl -s 'echo $WAYLAND_DISPLAY; read _; kill $PPID'; }
local -x WAYLAND_DISPLAY
@@ -587,34 +582,8 @@ pkg_setup() {
# (PORTAGE_SCHEDULING_POLICY) update...
addpredict /proc
- # May need a wider addpredict when using wayland+pgo.
- addpredict /dev/dri
-
- # Allow access to GPU during PGO run
- local ati_cards mesa_cards nvidia_cards render_cards
- shopt -s nullglob
-
- ati_cards=$(echo -n /dev/ati/card* | sed 's/ /:/g')
- if [[ -n "${ati_cards}" ]] ; then
- addpredict "${ati_cards}"
- fi
-
- mesa_cards=$(echo -n /dev/dri/card* | sed 's/ /:/g')
- if [[ -n "${mesa_cards}" ]] ; then
- addpredict "${mesa_cards}"
- fi
-
- nvidia_cards=$(echo -n /dev/nvidia* | sed 's/ /:/g')
- if [[ -n "${nvidia_cards}" ]] ; then
- addpredict "${nvidia_cards}"
- fi
-
- render_cards=$(echo -n /dev/dri/renderD128* | sed 's/ /:/g')
- if [[ -n "${render_cards}" ]] ; then
- addpredict "${render_cards}"
- fi
-
- shopt -u nullglob
+ # Clear tons of conditions, since PGO is hardware-dependant.
+ addpredict /dev
fi
if ! mountpoint -q /dev/shm ; then