summaryrefslogtreecommitdiff
path: root/www-client/otter/otter-0.9.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/otter/otter-0.9.12.ebuild')
-rw-r--r--www-client/otter/otter-0.9.12.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/www-client/otter/otter-0.9.12.ebuild b/www-client/otter/otter-0.9.12.ebuild
deleted file mode 100644
index 7ece4e1e4720..000000000000
--- a/www-client/otter/otter-0.9.12.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils cmake-utils gnome2-utils xdg-utils
-
-DESCRIPTION="Project aiming to recreate classic Opera (12.x) UI using Qt5"
-HOMEPAGE="http://otter-browser.org/"
-SRC_URI="https://github.com/Emdek/${PN}/archive/v${PV/_p/-dev}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="spell"
-
-DEPEND="
- dev-qt/qtconcurrent:5
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtdeclarative:5
- dev-qt/qtgui:5
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtprintsupport:5
- dev-qt/qtscript:5
- dev-qt/qtsql:5
- dev-qt/qtwebkit:5
- dev-qt/qtwidgets:5
- dev-qt/qtxmlpatterns:5
- spell? ( kde-frameworks/sonnet )
-"
-RDEPEND="
- ${DEPEND}
-"
-
-S=${WORKDIR}/${PN}-browser-${PV/_p/-dev}
-DOCS=( CHANGELOG CONTRIBUTING.md TODO )
-
-src_prepare() {
- cmake-utils_src_prepare
-
- if [[ -n ${LINGUAS} ]]; then
- local lingua
- for lingua in resources/translations/*.qm; do
- lingua=$(basename ${lingua})
- lingua=${lingua/otter-browser_/}
- lingua=${lingua/.qm/}
- if ! has ${lingua} ${LINGUAS}; then
- rm resources/translations/otter-browser_${lingua}.qm || die
- fi
- done
- fi
-
- if ! use spell; then
- sed -i -e '/find_package(KF5Sonnet)/d' CMakeLists.txt || die
- fi
-}
-
-src_install() {
- cmake-utils_src_install
- domenu ${PN}-browser.desktop
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}