summaryrefslogtreecommitdiff
path: root/www-misc/buku/buku-3.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc/buku/buku-3.6.ebuild')
-rw-r--r--www-misc/buku/buku-3.6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/www-misc/buku/buku-3.6.ebuild b/www-misc/buku/buku-3.6.ebuild
new file mode 100644
index 000000000000..ec2ba66f777d
--- /dev/null
+++ b/www-misc/buku/buku-3.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Powerful command-line bookmark manager"
+HOMEPAGE="https://github.com/jarun/Buku"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.13.1[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ )
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/zsh/site-functions
+ doins auto-completion/zsh/_*
+
+ newbashcomp auto-completion/bash/buku-completion.bash "${PN}"
+
+ doman buku.1
+}
+
+python_test() {
+ py.test -v tests/test_* || die
+}