summaryrefslogtreecommitdiff
path: root/www-servers/automx2
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/automx2')
-rw-r--r--www-servers/automx2/Manifest6
-rw-r--r--www-servers/automx2/automx2-2019.0.ebuild45
-rw-r--r--www-servers/automx2/files/conf20
-rw-r--r--www-servers/automx2/files/confd8
-rw-r--r--www-servers/automx2/files/init26
-rw-r--r--www-servers/automx2/metadata.xml26
6 files changed, 0 insertions, 131 deletions
diff --git a/www-servers/automx2/Manifest b/www-servers/automx2/Manifest
deleted file mode 100644
index 5b92bee95250..000000000000
--- a/www-servers/automx2/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-AUX conf 721 BLAKE2B 976a2936da5e9eef71d9d08f7f12c51151549c23c27918de28da355e87e4927f84cc63904ab0feb0d10a11326ce6e44cc11531d65f6abe3d1ce213ea2e632e24 SHA512 f931acb2e5060872219709b525d64cae630062eb842e55614d57324ff5e801b4b9a99faf47c706ffe67822b29a7fb680ed59db550470afa9ded80621d4bbe3b8
-AUX confd 213 BLAKE2B 2573f19bdc9022357f2f92ff17d84a1e77078c6c05a46a09b6e57ab7132d1f1078fb5003640f83213f746f94e3ab5b482b01d92feb94684665eb4e796a642841 SHA512 6c04de3ef26fd132269532c7bdca3263e95cebf5078ddd57e8ebff62229fabfb64b8ad4d988dfe99c9611c5d1081b4d3862f09d11c08aa1aabc1d5bc7c987439
-AUX init 611 BLAKE2B f84cd718a1ecfe2ed36fb875bde156e6b1700da5ddd115fb841a5d8cae638369238779647c113e1fea50a36069bdb1528917b31ca93b6d8d72686eedd7315c7a SHA512 3fccc3567428e1493daabc0bae87fb769bf7d8d807775ca7d1d3d7e4fdc982b176b3985f8b3b86a1dcbcab001227c685fdba7e08a8a343a2540ee3913412c721
-DIST automx2-2019.0.tar.bz2 46670 BLAKE2B 6f62b4429be8046fce18ccba6827879a99627d8fbe9cf7973d8059e87b4968a280b62d5d005aaed3b0e1074053f4a6355c34f2cdce2f06a9afb14c52b4504fb7 SHA512 e494a48ffd3e6d133a89db5afd1dc75116a8efcc41f0571a24271bcbe6074c86d62184ce00bae9ced888a70be7d20f2a3614f28007d4481537d42c680dca4daa
-EBUILD automx2-2019.0.ebuild 1069 BLAKE2B de5326157b1417388894589c361cd00f369da4066e436b6a02744eaa452af8517310102bd171f170837db88eba41869b19cda132acc30abd5d04db787e96034c SHA512 08d957ea357c94dbf5c77d8adf3bef16f1a6287f0898ff70ad4628b1e2ce193b015921600c6d9a913d361d92ea40d6c01e91a991298eb0189737347f5e49963a
-MISC metadata.xml 858 BLAKE2B 5bbb7cee2fd7850c48931da552112d5fc11ae61ab4a57787433dd10b750d717fbccb4e4c13f1d305ebbaa7831d8e56f2f81c304399ccbda5c88c1685bbfd76fd SHA512 31c591dd3b6dafc411232dcea7ca58690bb2690691a9a63d3243846ed5c51a417228778f632342fe327d8f50ce92a637d54705bf624000ef61a42b5866ade4df
diff --git a/www-servers/automx2/automx2-2019.0.ebuild b/www-servers/automx2/automx2-2019.0.ebuild
deleted file mode 100644
index bc55e2b7b7ec..000000000000
--- a/www-servers/automx2/automx2-2019.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Email client autoconfiguration service"
-HOMEPAGE="https://automx.org/"
-SRC_URI="https://gitlab.com/automx/automx2/-/archive/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc"
-
-BDEPEND="acct-user/automx2
- $(python_gen_cond_dep \
- '>=dev-python/flask-migrate-2.5.2[${PYTHON_MULTI_USEDEP}]' python3_{7}
- )"
-RDEPEND="${BDEPEND}"
-
-python_prepare_all() {
- sed -i -e "/('scripts'/d" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- export AUTOMX2_CONF="tests/unittest.conf"
- ${EPYTHON} -m unittest discover tests/ || die
-}
-
-python_install_all() {
- if use doc; then
- DOCS="*.adoc doc/*.adoc contrib/*sample.conf"
- HTML_DOCS="doc/*.html doc/*.svg"
- fi
- sed -e "s/@EPYTHON@/${EPYTHON}/" "${FILESDIR}/init" | newinitd - "${PN}"
- newconfd "${FILESDIR}/confd" "${PN}"
- insinto /etc
- newins "${FILESDIR}/conf" "${PN}.conf"
- distutils-r1_python_install_all
-}
diff --git a/www-servers/automx2/files/conf b/www-servers/automx2/files/conf
deleted file mode 100644
index ca19e0eebb68..000000000000
--- a/www-servers/automx2/files/conf
+++ /dev/null
@@ -1,20 +0,0 @@
-[automx2]
-# A typical production setup would use loglevel = WARNING
-loglevel = WARNING
-# Echo SQL commands into log? Used for debugging.
-db_echo = no
-
-# In-memory SQLite database
-#db_uri = sqlite:///:memory:
-
-# SQLite database in a UNIX-like file system
-db_uri = sqlite:////var/lib/automx2/db.sqlite
-
-# MySQL database on a remote server. This example does not use an encrypted
-# connection and is therefore *not* recommended for production use.
-#db_uri = mysql://username:password@server.example.com/db
-
-# Number of proxy servers between automx2 and the client (default: 0).
-# If your logs only show 127.0.0.1 or ::1 as the source IP for incoming
-# connections, proxy_count probably needs to be changed.
-#proxy_count = 1
diff --git a/www-servers/automx2/files/confd b/www-servers/automx2/files/confd
deleted file mode 100644
index 5a58d946aa23..000000000000
--- a/www-servers/automx2/files/confd
+++ /dev/null
@@ -1,8 +0,0 @@
-# Additional parameters passed to Flask
-#AUTOMX2_ARGS="--host 127.0.0.1 --port 4243"
-
-# Configuration file
-#AUTOMX2_CONF="/etc/automx2.conf"
-
-# Process owner (choose a non-privileged user)
-#AUTOMX2_USER="automx2"
diff --git a/www-servers/automx2/files/init b/www-servers/automx2/files/init
deleted file mode 100644
index 466461a6cd93..000000000000
--- a/www-servers/automx2/files/init
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-: ${AUTOMX2_CONF:="/etc/${RC_SVCNAME}.conf"}
-: ${AUTOMX2_USER:="automx2"}
-: ${AUTOMX2_ARGS:="--port 4243"}
-
-command="/usr/bin/python"
-command_args="/usr/bin/flask run ${AUTOMX2_ARGS}"
-command_background="true"
-command_user="${AUTOMX2_USER}"
-pidfile="/run/${RC_SVCNAME}.pid"
-required_files="${AUTOMX2_CONF}"
-
-depend() {
- use logger net
- before nginx
-}
-
-start_pre() {
- export AUTOMX2_CONF
- export EPYTHON="@EPYTHON@"
- export FLASK_APP="automx2.server:app"
- export FLASK_ENV="production"
-}
diff --git a/www-servers/automx2/metadata.xml b/www-servers/automx2/metadata.xml
deleted file mode 100644
index 1f4d3b2a0d4d..000000000000
--- a/www-servers/automx2/metadata.xml
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>gentoo@seichter.de</email>
- <name>Ralph Seichter</name>
- </maintainer>
- <maintainer type="project">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <longdescription>
- automx2 makes configuring a mail account easy. It unites
- methods for automated mailbox configuration from Apple
- (mobileconfig), Microsoft (autodiscover) and Mozilla
- (autoconfig) in one tool.
- </longdescription>
- <upstream>
- <doc>https://gitlab.com/automx/automx2/blob/master/doc/automx2.adoc</doc>
- <maintainer>
- <email>automx2@seichter.de</email>
- <name>Ralph Seichter</name>
- </maintainer>
- <remote-id type="gitlab">automx/automx2</remote-id>
- </upstream>
-</pkgmetadata>