summaryrefslogtreecommitdiff
path: root/www-servers/gunicorn/gunicorn-19.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/gunicorn/gunicorn-19.9.0.ebuild')
-rw-r--r--www-servers/gunicorn/gunicorn-19.9.0.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/www-servers/gunicorn/gunicorn-19.9.0.ebuild b/www-servers/gunicorn/gunicorn-19.9.0.ebuild
index a3c4673b2fcb..7a3d0bb71655 100644
--- a/www-servers/gunicorn/gunicorn-19.9.0.ebuild
+++ b/www-servers/gunicorn/gunicorn-19.9.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -13,25 +13,22 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT PSF-2 doc? ( BSD )"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
dev-python/unittest2[${PYTHON_USEDEP}]
)"
DOCS="README.rst"
distutils_enable_sphinx 'docs/source' --no-autodoc
+distutils_enable_tests pytest
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
+src_prepare() {
+ sed -e 's:--cov=gunicorn --cov-report=xml::' -i setup.cfg || die
+ distutils-r1_src_prepare
}
python_install_all() {